summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb')
-rw-r--r--meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb18
1 files changed, 16 insertions, 2 deletions
diff --git a/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb b/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
index babf8048a..c877d3bf1 100644
--- a/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
+++ b/meta-openembedded/meta-oe/recipes-test/cunit/cunit_2.1-3.bb
@@ -7,16 +7,30 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=7734aa853b85d6f935466f081490ddbb"
S = "${WORKDIR}/CUnit-${PV}"
SRC_URI = "${SOURCEFORGE_MIRROR}/project/cunit/CUnit/${PV}/CUnit-${PV}.tar.bz2 \
- file://fixup-install-docdir.patch"
+ file://fixup-install-docdir.patch \
+ file://run-ptest \
+ "
SRC_URI[md5sum] = "b5f1a9f6093869c070c6e4a9450cc10c"
SRC_URI[sha256sum] = "f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214"
UPSTREAM_CHECK_URI = "http://sourceforge.net/projects/cunit/files/releases"
-inherit autotools-brokensep remove-libtool
+inherit autotools-brokensep remove-libtool ptest
EXTRA_OECONF = "--enable-memtrace --enable-automated --enable-basic --enable-console"
+TESTBIN = "/CUnit/Sources/Test/test_cunit"
+
+PACKAGECONFIG ?= "${@bb.utils.contains('PTEST_ENABLED', '1', 'test','', d)} \
+ "
+
+PACKAGECONFIG[test] = "--enable-test,,,"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ install -m 0755 ${S}${TESTBIN} ${D}${PTEST_PATH}/tests/
+}
+
FILES_${PN}-dev += "${datadir}/CUnit"
FILES_${PN}-doc += "${docdir}"