summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:27:43 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-18 13:36:02 +0300
commitb809eb9d31058aad51fb82ff321a6bef45b23e58 (patch)
tree79e830e2b140780b96250c595592e1172bf31869 /meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
parent85521d71312d95503e78e3470267cbd4d7a6ecfa (diff)
downloadopenbmc-b809eb9d31058aad51fb82ff321a6bef45b23e58.tar.xz
meta-openembedded: subtree update:19528ba2a6..ef1b17f4ef
Callaghan, Dan (1): lmsensors: add a PACKAGECONFIG for sensord Changqing Li (1): ntp: fix package split wrongly when enabled usrmerge Khem Raj (1): remove spurious file Nathan Rossi (3): libeigen: Add native and nativesdk to BBCLASSEXTEND python*-pyusb: Add native and nativesdk to BBCLASSEXTEND python*-pyserial: Add native and nativesdk to BBCLASSEXTEND Oleksandr Kravchuk (23): babl: update to 0.1.62 znc: update to 1.7.4 zlog: update to 1.2.14 wipe: update to 0.24 upower: update to 0.99.11 python-pyobject: update to 3.34.0 python-pytoml: update to 0.1.21 python-cpuset: update to 1.6 libwebsockets: update to 3.2.0 libvpx: update to 1.8.1 libvdpau: update to 1.3 libmicrohttpd: update to 0.9.66 lcms: update to 2.9 libblockdev: update to 2.23 libbytesize: update to 2.1 iwd: update to 0.20 gsl: update to 2.6 gflags: update to 2.2.2 digitemp: update to 3.7.2 catch2: update to 2.9.2 botan: update to 2.11.0 agent-proxy: update to 1.97 ceres-solver: fix package version Paul Eggleton (1): mosquitto: update to 1.6.5 Scott Ellis (1): wireguard: Upgrade 20190905 to 20190913 Trevor Gamblin (1): openjpeg: upgrade 2.3.0 -> 2.3.1 Yi Zhao (1): samba: upgrade 4.10.7 -> 4.10.8 Zang Ruochen (2): python-dbus: upgrade 1.2.10 -> 1.2.12 python-pluggy: upgrade 0.12.0 -> 0.13.0 Zheng Ruoqin (1): xrdp: 0.9.4 -> 0.9.11 Change-Id: I3152060569cc5af7f7950c7037f25f54191d20a9 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
new file mode 100644
index 000000000..f08fa20a1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-dbus_1.2.12.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Python bindings for the DBus inter-process communication system"
+SECTION = "devel/python"
+HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
+LICENSE = "MIT & AFL-2.1 | GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4 \
+ file://dbus-gmain/COPYING;md5=99fece6728a80737c8fd3e7c734c17c4 "
+DEPENDS = "expat dbus dbus-glib virtual/libintl python-pyrex-native"
+
+SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
+"
+
+SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4"
+SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260"
+S = "${WORKDIR}/dbus-python-${PV}"
+
+inherit distutils-base autotools pkgconfig
+
+# documentation needs python-sphinx, which is not in oe-core or meta-python for now
+# change to use PACKAGECONFIG when python-sphinx is added to oe-core or meta-python
+EXTRA_OECONF += "--disable-documentation"
+
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+RDEPENDS_${PN} = "python-io python-logging python-stringold python-threading python-xml"
+
+FILES_${PN}-dev += "${libdir}/pkgconfig"
+
+do_install_append() {
+ # Remove files that clash with python3-dbus; their content is same
+ rm ${D}${includedir}/dbus-1.0/dbus/dbus-python.h ${D}${libdir}/pkgconfig/dbus-python.pc
+}