summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-10-28 20:16:02 +0300
commitda710c8bb0dea17982efc20ab4ee226a86992e6f (patch)
tree06c83c9e85c881f40532972aaa1453298236e029 /meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb
parent6656af78e6c7b48a1252459a61b3b72dce77ab44 (diff)
parent2795589128d1f7509ac0ab9eba940d868413ac7d (diff)
downloadopenbmc-da710c8bb0dea17982efc20ab4ee226a86992e6f.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb
new file mode 100644
index 000000000..2b5ee9e7e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pip_19.3.bb
@@ -0,0 +1,14 @@
+SUMMARY = "PIP is a tool for installing and managing Python packages"
+HOMEPAGE = "https://pip.pypa.io/"
+LICENSE = "MIT & LGPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=8ba06d529c955048e5ddd7c45459eb2e"
+
+SRC_URI[md5sum] = "a57da8b758cbf1a155cde6a7a4428ba7"
+SRC_URI[sha256sum] = "324d234b8f6124846b4e390df255cacbe09ce22791c3b714aa1ea6e44a4f2861"
+
+inherit pypi setuptools
+
+# Since PIP is like CPAN for PERL we need to drag in all python modules to ensure everything works
+RDEPENDS_${PN}_class-target = "python-modules python-distribute python-misc"
+
+BBCLASSEXTEND = "native nativesdk"