summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
committerJason M. Bills <jason.m.bills@intel.com>2022-01-06 23:59:39 +0300
commit32777eec25d2c527a62e5ffab90a3dfef35855aa (patch)
tree588a90a6fe9fb0b35c7ce23ea3bd79fa5151ccde /meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
parent61f1ca1b31a9a1108e9e7f71e47fdc19beb0490b (diff)
parent5cc2f81c5b66da00cad24e18b0d23442af060c3f (diff)
downloadopenbmc-32777eec25d2c527a62e5ffab90a3dfef35855aa.tar.xz
Merge tag '0.86' of firmware.bmc.openbmc.yocto.openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
new file mode 100644
index 000000000..2632ce1c8
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_2.2.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "Extra features for standard library's cmd module"
+HOMEPAGE = "https://github.com/python-cmd2/cmd2"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4c527bcb481233ebcb803de975f42701"
+
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
+SRC_URI[sha256sum] = "34cd12424d9e2835eff125146af3d9f4a4c2931c6bc5a3cea9790bd4f55756d9"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-attrs \
+ ${PYTHON_PN}-colorama \
+ ${PYTHON_PN}-pyperclip \
+ ${PYTHON_PN}-wcwidth \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-pydoc \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-numbers \
+"
+
+BBCLASSEXTEND = "native nativesdk"