summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-01-27 22:27:17 +0300
commit98cc5cd6483975b64d80e8323f7f659dd1337d75 (patch)
tree5fa64e93d57396bc4c76aa3537156205b4b424ac /meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb
parent82dbc15a05125a812c140a3c8cff81c366482229 (diff)
parent8fc454f9beebdd347403145c991697019a593cff (diff)
downloadopenbmc-98cc5cd6483975b64d80e8323f7f659dd1337d75.tar.xz
Merge tag '0.29' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb
new file mode 100644
index 000000000..e3691dd83
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-dateparser_1.0.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Provides modules to easily parse localized dates in almost any string formats commonly found on web pages"
+HOMEPAGE = "https://github.com/scrapinghub/dateparser"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d3ed25571191e7aa3f55d0a6efe0051"
+
+SRC_URI[md5sum] = "24a06a429597239004d47e6b93991aaf"
+SRC_URI[sha256sum] = "159cc4e01a593706a15cd4e269a0b3345edf3aef8bf9278a57dac8adf5bf1e4a"
+
+PYPI_PACKAGE = "dateparser"
+
+inherit pypi setuptools3
+
+CLEANBROKEN = "1"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-dateutil \
+ ${PYTHON_PN}-tzlocal \
+ ${PYTHON_PN}-ruamel-yaml \
+"
+
+# Ommitted ${PYTHON_PN}-convertdate, ${PYTHON_PN}-jdatetime ${PYTHON_PN}-umalqurra