summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2022-01-18 21:55:05 +0300
committerGitHub <noreply@github.com>2022-01-18 21:55:05 +0300
commit7cf0c1cd0ce835d1833509b7b911e8a97380278b (patch)
tree0b45c3beaa9874facc4ed1a2395a31e42be0135d /meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb
parent4dac5fcd49b5e2de1074f1363775ec0f19041072 (diff)
parent1fc0d70f658da30091bcd49f9bf29aecd6b99ba7 (diff)
downloadopenbmc-7cf0c1cd0ce835d1833509b7b911e8a97380278b.tar.xz
Merge pull request #76 from Intel-BMC/update1-0.86
Update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb
new file mode 100644
index 000000000..2e44c3d80
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-decorator_5.1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Python decorator utilities"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
+
+SRC_URI[sha256sum] = "e59913af105b9860aa2c8d3272d9de5a56a4e608db9a2f167a8480b323d529a7"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-stringold \
+ "