summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
diff options
context:
space:
mode:
authorjmbills <42755197+jmbills@users.noreply.github.com>2020-07-11 02:37:34 +0300
committerGitHub <noreply@github.com>2020-07-11 02:37:34 +0300
commit2a11ae52fca0d1c0e12b4f18da637645eecc213c (patch)
tree05a1d365e0faa6ce8570b2d0c2d0f100dc8df1d4 /meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
parentefa39df15c70a1ab300cfa87e9895d5ee1feb5be (diff)
parentd071adf43ac87f21dde2f84287120960c723962c (diff)
downloadopenbmc-2a11ae52fca0d1c0e12b4f18da637645eecc213c.tar.xz
Merge pull request #44 from Intel-BMC/update
Update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
new file mode 100644
index 000000000..cfff150cc
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-et-xmlfile_1.0.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "et_xmlfile is a low memory library for creating large XML files"
+DESCRIPTION = "It is based upon the xmlfile module from lxml with the aim of allowing code \
+to be developed that will work with both libraries. It was developed initially for \
+the openpyxl project but is now a standalone module."
+
+HOMEPAGE = "https://bitbucket.org/openpyxl/et_xmlfile/src/default/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=b3d89cae66f26c3a0799be8a96f3178b"
+
+SRC_URI[md5sum] = "f47940fd9d556375420b2e276476cfaf"
+SRC_URI[sha256sum] = "614d9722d572f6246302c4491846d2c393c199cfa4edc9af593437691683335b"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-compression ${PYTHON_PN}-io ${PYTHON_PN}-pprint ${PYTHON_PN}-shell"
+
+inherit setuptools3
+PYPI_PACKAGE ?= "et_xmlfile"
+PYPI_SRC_URI ?= "https://files.pythonhosted.org/packages/source/e/et_xmlfile/et_xmlfile-1.0.1.tar.gz"
+SECTION = "devel/python"
+SRC_URI += "${PYPI_SRC_URI}"
+S = "${WORKDIR}/${PYPI_PACKAGE}-${PV}"