summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-fann2
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-08 22:21:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-04-08 22:21:12 +0300
commit34ae60030e520db4235f13b99849052e594fde7b (patch)
treef672a23d5bf8d8cf74737e80a304c55766a7d596 /meta-openembedded/meta-python/recipes-devtools/python/python3-fann2
parent4e3797a177a8edd3909ab428353e5186447b8312 (diff)
downloadopenbmc-34ae60030e520db4235f13b99849052e594fde7b.tar.xz
meta-openembedded: refresh master: 0435c9e193..4a9deabbc8
Update meta-openembedded to master HEAD. Alistair Francis (7): python3-pyaudio: Initial commit python3-pyfann2: Initial commit python3-pocketsphinx: Initial commit python3-xxhash: Initial commit mycroft: Initial commit libfann: Initial commit python-cryptography: Bump from 2.4.1 to 2.6.1 Andreas Müller (10): xfce4-screenshooter: upgrade 1.9.4 -> 1.9.5 networkmanager: Fix upstream regex for 1.16 networkmanager: fix build with musl gvfs: fix configure options and DDEPENDS rrdtool: fix build by disabling docs libpeas: rework gobject-introspection handling gvfs: Fix missing executable permission flags for files in libexec gnome-desktop3: remove gconf from DEPENDS gnome-desktop3: rework gobject-introspection handling gnome-desktop3: Disable libseccomp for all archs Brad Bishop (1): libvncserver: enable split client/server packages Fabio Berton (1): python*-requests: Update 2.20.1 -> 2.21.0 Gianfranco Costamagna (2): cpprest: fix build failure on 32bit systems, with upstream merged patch libmodbus: start to prefer version 3.1.4 as default Hongxu Jia (1): dracut: fix udevdir not found Khem Raj (5): ncmpc: Rename artist_screen to library_screen networkmanager: Fix build with clang alsa-oss: Upgrade to 1.1.8 redis: Fix ocasional parallel build failure lcdproc: Fix parallel build Nikolay Nizov (2): android-tools-conf: fix typo android-tools-conf: Make sure /dev/pts/0 exists Oleksandr Kravchuk (2): fping: update to 4.2 nuttcp: update to 7.3.3 Peter Kjellerstedt (1): doxygen: Make it build with ninja 1.9.0 Qi.Chen@windriver.com (2): openldap: add missing CVE tag to patch ipsec-tools: add missing CVE tags to patches Randy MacLeod (2): imagemagic: upgrade to 7.0.8-35 wolfssl: update to 3.15.8 and use github SRC_URI Slater, Joseph (1): tcpreplay: update to version 4.3.2 Vincent Prince (4): Rsyslog: Add mmjsonparse to PACKAGECONFIG zeromq: bump version 4.2.5 => 4.3.1 cppzmq: bump version 4.2.3 => 4.3.0 czmq: bump version 4.1.1 => 4.2.0 Yi Zhao (3): python-engineio: add recipe python-socketio: add recipe python-flask-socketio Zang Ruochen (4): augeas: upgrade 1.10.1 -> 1.11.0 libedit: upgrade 20181209-3.1 -> 20190324-3.1 mcelog: upgrade 161 -> 162 lockfile-progs: upgrade 0.1.17 -> 0.1.18 leimaohui (1): Fix build error for armeb. Change-Id: Ie79748c484bcf4fd28b3bde84e2194044e1c08a8 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-fann2')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch
new file mode 100644
index 000000000..cbc838f0e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch
@@ -0,0 +1,28 @@
+From 85307f592c7cb87af162cca4b121b874108b7754 Mon Sep 17 00:00:00 2001
+From: Alistair Francis <alistair.francis@wdc.com>
+Date: Tue, 2 Apr 2019 11:25:15 -0700
+Subject: [PATCH] setup.py: Don't hardcode swig and fann2 binary locations
+
+Upstream-Status: Inappropriate [configuration]
+Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
+---
+ setup.py | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 37af7c7..8e416f2 100755
+--- a/setup.py
++++ b/setup.py
+@@ -81,11 +81,8 @@ def find_swig():
+
+ def build_swig():
+ '''Run SWIG with specified parameters'''
+- print("Looking for FANN libs...")
+- find_fann()
+- print("running SWIG...")
+ swig_bin = find_swig()
+- swig_cmd = [swig_bin, '-c++', '-python', 'fann2/fann2.i']
++ swig_cmd = ['swig', '-c++', '-python', 'fann2/fann2.i']
+ subprocess.Popen(swig_cmd).wait()
+
+ if "sdist" not in sys.argv: