summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-08-31 21:23:16 +0300
committerGitHub <noreply@github.com>2021-08-31 21:23:16 +0300
commit04cd92067d2481643df5010cb39b2134b648cf4d (patch)
treed98626c9763ad9048ac9bfd8269e12eced18d496 /meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
parent10ad77d5bc86709d8ff7f95e7040e39f1c153903 (diff)
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
downloadopenbmc-04cd92067d2481643df5010cb39b2134b648cf4d.tar.xz
Merge pull request #70 from Intel-BMC/update2021-0.701-0.70
Update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
new file mode 100644
index 000000000..676e1dbdc
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+HOMEPAGE = "http://networkx.github.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5cfa4d8f5881e0d053bb497130b9c73a"
+
+SRC_URI[sha256sum] = "bf4cb807d1bccf1593c7d0742d9127d9e04e021867299082658b0fc3907924e8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-json \
+ "