summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-09-28 20:46:50 +0300
commitd73e39703a0260c8911cb439b579e1c2bada4b20 (patch)
tree4fa9f965ae954c587ab773ecaced6b8f8e18d359 /meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb
parent6f106a0a4ce15fe0678d4ffefd572e6978c72597 (diff)
parent6d8c5d2c6204714ca6b7a43f04348162b683cdbc (diff)
downloadopenbmc-d73e39703a0260c8911cb439b579e1c2bada4b20.tar.xz
Merge tag '0.75' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb
new file mode 100644
index 000000000..e7676a713
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.6.2.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+HOMEPAGE = "http://networkx.github.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5cfa4d8f5881e0d053bb497130b9c73a"
+
+SRC_URI[sha256sum] = "2306f1950ce772c5a59a57f5486d59bb9cab98497c45fc49cbc45ac0dec119bb"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-json \
+ "