summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2021-04-19 22:02:49 +0300
commit36caa12533da01d4319c5ffe7613711a0ec7dea7 (patch)
tree591c2077bb14cfd9d23893d32cca71fa7a01bc9c /meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb
parent12bef3e1bf292dec5ac15af9fb41e86f7bcfb0cb (diff)
parent3cec7f5a630c1ddcad058eb76e1f732a5fa20d59 (diff)
downloadopenbmc-36caa12533da01d4319c5ffe7613711a0ec7dea7.tar.xz
Merge tag '0.45' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb
new file mode 100644
index 000000000..9e3cbb43e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-periphery_2.3.0.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "A pure Python 2/3 library for peripheral I/O (GPIO, LED, PWM, SPI, I2C, MMIO, Serial) in Linux."
+HOMEPAGE = "http://pythonhosted.org/python-periphery/"
+LICENSE = "MIT"
+
+LIC_FILES_CHKSUM = "file://LICENSE;md5=fed1784a083509430580a913df680706"
+
+SRC_URI[sha256sum] = "8a8ec019d9b330a6a6f69a7de61d14b4c98b102d76359047c5ce0263e12246a6"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "python-periphery"
+
+RDEPENDS_${PN} += "${PYTHON_PN}-mmap \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-fcntl"