summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb
diff options
context:
space:
mode:
authorjmbills <jasonm.bills@yahoo.com>2021-06-02 20:10:10 +0300
committerGitHub <noreply@github.com>2021-06-02 20:10:10 +0300
commite7436234669703196c5ed56f33050d2dc19127cd (patch)
tree704eb802dc7b987411a0e44d128bdd8978745d8c /meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb
parent2ac88c6ae92b615338771db8a4fcbef91bee0947 (diff)
parent2a64b8ae9b952b18b4aef38cb7c41ce6dba16c50 (diff)
downloadopenbmc-e7436234669703196c5ed56f33050d2dc19127cd.tar.xz
Merge pull request #67 from Intel-BMC/update2021-0.521-0.52
Update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb
new file mode 100644
index 000000000..439d383f8
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pyroute2_0.5.18.bb
@@ -0,0 +1,36 @@
+SUMMARY = "A pure Python netlink and Linux network configuration library"
+LICENSE = "GPLv2 & Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce"
+
+SRC_URI[sha256sum] = "08ac40cad52c0bb2e0f20087520599aa91fcce0b221dd26e9042330428810bc5"
+
+inherit setuptools3 pypi ptest
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-ctypes \
+ ${PYTHON_PN}-distutils \
+ ${PYTHON_PN}-io \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-logging \
+ ${PYTHON_PN}-multiprocessing \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-pkgutil \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-shell \
+ ${PYTHON_PN}-unixadmin \
+"
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-fcntl \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}