summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2020-12-08 00:38:17 +0300
commit8d6ae7f2a817751fad151168fa10ce28ee0869d8 (patch)
tree281032f7ec07c41589aa094bd165cc2a98f2d3a7 /meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
parentc16fb8893b19075db4bcf3b5bf33c1db8c3ca2bd (diff)
parent5da3c2284560a7e08ffafd03c5b5ba44a3242228 (diff)
downloadopenbmc-8d6ae7f2a817751fad151168fa10ce28ee0869d8.tar.xz
Merge tag '0.26' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
new file mode 100644
index 000000000..2108cbb93
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-watchdog_0.10.3.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Filesystem events monitoring"
+DEPENDS = "${PYTHON_PN}-argh"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[md5sum] = "9a5c9134e943b534b9f8b51d78338cf8"
+SRC_URI[sha256sum] = "4214e1379d128b0588021880ccaf40317ee156d4603ac388b9adcf29165e0c04"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} = " \
+ ${PYTHON_PN}-argh \
+ ${PYTHON_PN}-pathtools3 \
+ ${PYTHON_PN}-pyyaml \
+ ${PYTHON_PN}-requests \
+"
+
+BBCLASSEXTEND = "native nativesdk"