summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-26 08:32:28 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-26 08:32:33 +0300
commit665fd026517259031fd55bcfb2a9dab0d9f3582a (patch)
tree4152d42430b07cd519c82b91d9c1abc88b5a5a6a /meta-openembedded/meta-python/recipes-devtools/python
parent36166cd035bf51c6830b977e48316d708daa62b5 (diff)
downloadopenbmc-665fd026517259031fd55bcfb2a9dab0d9f3582a.tar.xz
meta-openembedded: subtree update:509d40153d..1e8bc46e55
Adrian Bunk (5): networkmanager: musl now supports secure_getenv libuser: musl now supports secure_getenv libgit2: Upgrade 0.27.8 -> 0.27.9 poppler: Stop using USE_FIXEDPOINT networkmanager: Upgrade 1.18.0 -> 1.18.2 Andreas Müller (10): xfce4-time-out-plugin: upgrade 1.0.2 -> 1.0.3 xfce4-battery-plugin: 1.1.2 -> 1.1.3 xfce4-smartbookmark-plugin: upgrade 0.5.0 -> 0.5.1 xfce4-wavelan-plugin: upgrade 0.6.0 -> 0.6.1 xfce4-netload-plugin: upgrade 1.3.1 -> 1.3.2 xfce4-systemload-plugin: upgrade 1.2.2 -> 1.2.3 xfce4-mpc-plugin: upgrade 0.5.1 -> 0.5.2 xfce4-fsguard-plugin: upgrade 1.1.0 -> 1.1.1 xfce4-diskperf-plugin: upgrade 2.6.1 -> 2.6.2 gigolo: upgrade 0.4.2 -> 0.5.0 Anuj Mittal (2): clinfo: add recipe ade: add recipe Hongxu Jia (1): lvm2: fix circular dependencies while systemd enable cryptsetup Jan Kaisrlik (1): networkd-dispatcher: service file is using different location of binary Johannes Pointner (1): libtinyxml2: update to 7.1.0 Martin Jansa (1): python-socketio: prevent python2 socketio depending on python3-aiohttp Piotr Tworek (3): libgee: Update to version 0.20.2 gnome-bluetooth: Update to version 3.32.1. gnome-keyring: Update to version 3.28.2 Yi Zhao (1): apache2: upgrade 2.4.39 -> 2.4.41 Yuan Chao (5): libnftnl: upgrade 1.1.3 -> 1.1.4 libtdb: upgrade 1.4.0 -> 1.4.1 python-flask-pymongo: upgrade 0.5.1 -> 2.3.0 xfsprogs: upgrade 5.2.0 -> 5.2.1 python-protobuf: upgrade 3.9.0 -> 3.9.1 Zang Ruochen (1): cryptsetup: upgrade 2.1.0 -> 2.2.0. Change-Id: I4db480893fc3b39cc7e014dbca0adc9c5317abf1 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc6
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc6
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb2
8 files changed, 11 insertions, 7 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
index fb2d6ed8b..39251525b 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo.inc
@@ -5,9 +5,11 @@ SECTION = "devel/python"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://flask_pymongo/wrappers.py;beginline=1;endline=24;md5=424c4e1047d28e01b4e4634a069c019d"
-SRC_URI[md5sum] = "d7a1b717f27154e1f3a355f8ec2467d6"
-SRC_URI[sha256sum] = "2baaa2ba5107d72b3a8bd4b5c0c8881316e35340ad1ae979cc13f1f3c8843b3d"
+SRC_URI[md5sum] = "94df71e6800b1d7915cc91a74b70f959"
+SRC_URI[sha256sum] = "620eb02dc8808a5fcb90f26cab6cba9d6bf497b15032ae3ca99df80366e33314"
PYPI_PACKAGE = "Flask-PyMongo"
+DEPENDS = "${PYTHON_PN}-vcversioner ${PYTHON_PN}-vcversioner-native"
+
RDEPENDS_${PN} = "${PYTHON_PN}-pymongo ${PYTHON_PN}-flask"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb
index d41d02348..d41d02348 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_0.5.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-flask-pymongo_2.3.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
index b13f10e36..ce95e66c9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec
inherit pypi
-SRC_URI[md5sum] = "4ec7b2d49a5d1460591e520b54153c87"
-SRC_URI[sha256sum] = "b3452bbda12b1cbe2187d416779de07b2ab4c497d83a050e43c344778763721d"
+SRC_URI[md5sum] = "ca881f18795e024a2b935d5bae9b1ebe"
+SRC_URI[sha256sum] = "d831b047bd69becaf64019a47179eb22118a50dd008340655266a906c69c6417"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb
index f04fc489f..f04fc489f 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
index 7ebc4eac7..7ee99f8d9 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-socketio.inc
@@ -12,9 +12,9 @@ PYPI_PACKAGE = "python-socketio"
SRC_URI[md5sum] = "86cd47dddea1785ce7a6c72f55c93fe7"
SRC_URI[sha256sum] = "506b2cf7a520b40ea0b3f25e1272eff8de134dce6f471c1f6bc0de8c90fe8c57"
-PACKAGECONFIG ?= "asyncio_client client"
-PACKAGECONFIG[asyncio_client] = ",,,python3-aiohttp python3-websockets"
-PACKAGECONFIG[client] = ",,,python3-requests python3-websocket-client"
+PACKAGECONFIG ?= ""
+PACKAGECONFIG[asyncio_client] = ",,,${PYTHON_PN}-aiohttp ${PYTHON_PN}-websockets"
+PACKAGECONFIG[client] = ",,,${PYTHON_PN}-requests ${PYTHON_PN}-websocket-client"
RDEPENDS_${PN} += "\
${PYTHON_PN}-engineio \
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb
index 2102554b6..2102554b6 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_0.5.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-flask-pymongo_2.3.0.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb
index 30ea34e90..30ea34e90 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
index ce83d09c0..8ff590bd7 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-socketio_4.3.1.bb
@@ -1,2 +1,4 @@
inherit setuptools3
+
+PACKAGECONFIG ?= "asyncio_client client"
require python-socketio.inc