summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-devtools/python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-10 14:20:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-10 14:20:04 +0300
commit5f78ea18ab7503162e715c306f55312f154d3705 (patch)
tree2388490d970f10299cb1f84772438c6c6a8dafd2 /meta-openembedded/meta-python/recipes-devtools/python
parentea52c6b623935aab36bcc5fb59638541c314defc (diff)
downloadopenbmc-5f78ea18ab7503162e715c306f55312f154d3705.tar.xz
meta-openembedded: subtree update:3061ead8cf..ce51958eca
Adrian Bunk (1): librcf: Remove, PNBLACKLIST since April 2018 Khem Raj (3): openocd: disable werror when building with gcc kernel-selftest: Needs error.h which is missing in musl remmina: Add space before append operation Zheng Ruoqin (2): python-prettytable: Add python3 version python3-colorama: New recipe aehs29@gmail.com (1): remmina: Fix spice protocol dependency and configuration Change-Id: Ia4674cf3ab186b06c25f0601e02ddc00c96b781f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python/recipes-devtools/python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-prettytable.inc25
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb26
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-colorama_0.4.1.bb10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb3
4 files changed, 39 insertions, 25 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable.inc
new file mode 100644
index 000000000..6004ecd33
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable.inc
@@ -0,0 +1,25 @@
+SUMMARY = "Python library for displaying tabular data in a ASCII table format"
+HOMEPAGE = "http://code.google.com/p/prettytable"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
+
+SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
+SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
+
+SRCNAME = "prettytable"
+
+SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+do_install_append() {
+ perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
+ for f in $perm_files; do
+ chmod 644 "${f}"
+ done
+}
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
+UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
index 406555ac3..69ff25927 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-prettytable_0.7.2.bb
@@ -1,27 +1,3 @@
-SUMMARY = "Python library for displaying tabular data in a ASCII table format"
-HOMEPAGE = "http://code.google.com/p/prettytable"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=3e73500ffa52de5071cff65990055282"
-
-SRC_URI[md5sum] = "0c1361104caff8b09f220748f9d69899"
-SRC_URI[sha256sum] = "a53da3b43d7a5c229b5e3ca2892ef982c46b7923b51e98f0db49956531211c4f"
-
-SRCNAME = "prettytable"
-
-SRC_URI = "https://pypi.python.org/packages/source/P/PrettyTable/${SRCNAME}-${PV}.zip"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
inherit setuptools
+require python-prettytable.inc
-do_install_append() {
- perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "*.txt" -o -name "PKG-INFO"`
- for f in $perm_files; do
- chmod 644 "${f}"
- done
-}
-
-UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/PrettyTable/"
-UPSTREAM_CHECK_REGEX = "/PrettyTable/(?P<pver>(\d+[\.\-_]*)+)"
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-colorama_0.4.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-colorama_0.4.1.bb
new file mode 100644
index 000000000..9cfca094e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-colorama_0.4.1.bb
@@ -0,0 +1,10 @@
+SUMMARY = "Cross-platform colored terminal text."
+HOMEPAGE = "https://github.com/tartley/colorama"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4936429a56a652b84c5c01280dcaa26"
+
+inherit pypi setuptools3
+
+SRC_URI[md5sum] = "f927529cd1735f6f50ee2c61628e9c1f"
+SRC_URI[sha256sum] = "05eed71e2e327246ad6b38c540c4a3117230b19679b875190486ddd2d721422d"
+
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
new file mode 100644
index 000000000..5445f1019
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-prettytable_0.7.2.bb
@@ -0,0 +1,3 @@
+inherit setuptools3
+require python-prettytable.inc
+