summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
diff options
context:
space:
mode:
authorEd Tanous <ed.tanous@intel.com>2019-07-31 20:59:18 +0300
committerEd Tanous <ed.tanous@intel.com>2019-07-31 20:59:18 +0300
commitb4f66bacb1b8e661d794fa7a189e2f66f5092e2e (patch)
tree5a8302cd349fdb68dadca003483c61917d4a6add /meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
parent43a183cc0926da36e3a218efa02ab4838ace316f (diff)
parentdd755025e33af27b059ea7ef3afbe850e4880b08 (diff)
downloadopenbmc-b4f66bacb1b8e661d794fa7a189e2f66f5092e2e.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into intel
Diffstat (limited to 'meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb')
-rw-r--r--meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb9
1 files changed, 8 insertions, 1 deletions
diff --git a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb b/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
index 741074907..a699f1c7e 100644
--- a/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
+++ b/meta-openembedded/meta-python/recipes-extended/pywbem/python-pywbem_0.11.0.bb
@@ -1,5 +1,5 @@
require python-pywbem.inc
-inherit setuptools
+inherit setuptools update-alternatives
DEPENDS += " \
${PYTHON_PN}-m2crypto-native \
@@ -11,3 +11,10 @@ RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-m2crypto \
${PYTHON_PN}-subprocess \
"
+
+ALTERNATIVE_${PN} = "mof_compiler pywbemcli wbemcli"
+ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
+ALTERNATIVE_TARGET[pywbemcli] = "${bindir}/pywbemcli"
+ALTERNATIVE_TARGET[wbemcli] = "${bindir}/wbemcli"
+
+ALTERNATIVE_PRIORITY = "30"