summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-13 13:17:50 +0300
commita891d150c6a7455ddbb797bdc472f45fd5f36008 (patch)
tree675a1c6f76065884b0c99b5a6056c79de44ef083 /meta-openembedded/meta-python
parent4bfffde7b5edeee761d32b174386bd1e1e28fab9 (diff)
downloadopenbmc-a891d150c6a7455ddbb797bdc472f45fd5f36008.tar.xz
meta-openembedded: subtree update:ce51958eca..a2928764c2
Adrian Bunk (3): python3-cmd2: Remove PNBLACKLIST php: Remove no longer needed CFLAGS_append_aarch64 php: Move more into php.inc after php5 removal Alistair Francis (4): python3-requests-future: Initial commit of 0.9.5 python3-xmlrunner: Initial commit of 1.7.7 python3-fasteners: Initial commit of 0.15 python3-python-vlc: Initial commit of 3.0.7110 Anuj Mittal (3): python3-defusedxml: add recipe python-networkx: upgrade 2.1 -> 2.2 python3-networkx: add recipe Khem Raj (9): php: Turn PCRE JIT off for riscv redis: Fix build with clang/x86 android-tools: Recognise i686 for HOST_ARCH netdata: Update to 1.17.0 and fix build with clang/x86 safec: Define _GNU_SOURCE safec: Upgrade to 3.5 release openocd: Add --disable-werror always breakpad: Update dont-clobber-rsp patch to latest gparted: add to deps instead of overwriting Martin Jansa (3): remmina: add distro_features_check for GTK3DISTROFEATURES ceres-solver: fix the paths in .cmake files ceres-solver: add PACKAGECONFIG for suitesparse and lapack Naveen Saini (1): pm-graph: upgrade 5.3 -> 5.5 Oleksandr Kravchuk (1): analyze-suspend: update to 5.5 Peter Kjellerstedt (1): lvm2/libdevmapper: Make it build for native Randy MacLeod (1): poppler: update from 0.79.0 to 0.80.0 Slater, Joseph (1): openhpi: control snmp-bc ptest generation Stefan Agner (1): fuse3: add libfuse3 recipe Trevor Gamblin (1): gvfs: upgrade 1.40.2 -> 1.41.2 for CVE fixes Yi Zhao (2): php: fix module path in mod_php.conf apache-websocket: fix module path Yuan Chao (2): python-atomicwrites: new recipe python-pytest: fix runtime error Zang Ruochen (1): python-certifi: upgrade 2019.6.16 -> 2019.9.11 Change-Id: Iba065b25686a1ac22d647226d9ea0c61c5b4578f Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites.inc7
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites_1.3.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.9.11.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-networkx.inc10
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.1.bb12
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.2.bb8
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.9.11.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-defusedxml_0.6.0.bb11
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-fasteners_0.15.bb9
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.3.bb8
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-python-vlc_3.0.7110.bb9
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb14
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-xmlrunner_1.7.7.bb9
17 files changed, 92 insertions, 15 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites.inc
new file mode 100644
index 000000000..773e9dd77
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites.inc
@@ -0,0 +1,7 @@
+DESCRIPTION = "Powerful Python library for atomic file writes"
+HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
+
+SRC_URI[md5sum] = "ce11f780a4ce0fce8a55d64494a88178"
+SRC_URI[sha256sum] = "75a9445bac02d8d058d5e1fe689654ba5a6556a1dfd8ce6ec55a0ed79866cfa6"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites_1.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites_1.3.0.bb
new file mode 100644
index 000000000..c7b41d603
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-atomicwrites_1.3.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools
+require python-atomicwrites.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
index 23e18563a..de02d9a4a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi.inc
@@ -7,7 +7,7 @@ HOMEPAGE = " http://certifi.io/"
LICENSE = "ISC"
LIC_FILES_CHKSUM = "file://LICENSE;md5=f77f61d14ee6feac4228d3ebd26cc1f1"
-SRC_URI[md5sum] = "af8fea5f3df6f7f81e9c6cbc6dd7c1e8"
-SRC_URI[sha256sum] = "945e3ba63a0b9f577b1395204e13c3a231f9bc0223888be653286534e5873695"
+SRC_URI[md5sum] = "cadd4e373fc08f649fa39b82aed9ad96"
+SRC_URI[sha256sum] = "e4f3620cfea4f83eedc95b24abd9cd56f3c4b146dd0177e83a21b4eb49e21e50"
BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.9.11.bb
index adfe6238e..adfe6238e 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.6.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-certifi_2019.9.11.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-networkx.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-networkx.inc
new file mode 100644
index 000000000..a4c31b2b2
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-networkx.inc
@@ -0,0 +1,10 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+LICENSE = "BSD-3-Clause"
+
+inherit pypi
+
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-decorator \
+ "
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.1.bb
deleted file mode 100644
index bc0c6863d..000000000
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "Python package for creating and manipulating graphs and networks"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
-
-SRC_URI[md5sum] = "4a2c2a62dfc46ba7d594daca7c834995"
-SRC_URI[sha256sum] = "64272ca418972b70a196cb15d9c85a5a6041f09a2f32e0d30c0255f25d458bb1"
-
-PYPI_PACKAGE_EXT = "zip"
-
-inherit pypi setuptools
-
-RDEPENDS_${PN} += "python-2to3"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.2.bb
new file mode 100644
index 000000000..648f0312f
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-networkx_2.2.bb
@@ -0,0 +1,8 @@
+require python-networkx.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3376ff7c9c58048c62d91431f7f08cde"
+
+SRC_URI[md5sum] = "82608a3686fb3e61f20cf13bfd3c1b4a"
+SRC_URI[sha256sum] = "45e56f7ab6fe81652fb4bc9f44faddb0e9025f469f602df14e3b2551c2ea5c8b"
+
+inherit setuptools
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
index b58cdea96..7ef6092b5 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-pytest.inc
@@ -20,6 +20,7 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-py \
${PYTHON_PN}-setuptools \
${PYTHON_PN}-six \
+ ${PYTHON_PN}-atomicwrites \
"
FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb
new file mode 100644
index 000000000..9f306e60d
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb
@@ -0,0 +1,2 @@
+inherit pypi setuptools3
+require python-atomicwrites.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.9.11.bb
index 70f674b22..70f674b22 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.6.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-certifi_2019.9.11.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
index 594e93dca..f5c5c7e1a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
@@ -7,4 +7,3 @@ RDEPENDS_${PN} += "\
${PYTHON_PN}-attrs \
${PYTHON_PN}-wcwidth \
"
-PNBLACKLIST[python3-cmd2] = "Nothing RPROVIDES 'python3-colorama' (but python3-cmd2_0.9.16.bb RDEPENDS on or otherwise requires it)"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-defusedxml_0.6.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-defusedxml_0.6.0.bb
new file mode 100644
index 000000000..d041d0e6c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-defusedxml_0.6.0.bb
@@ -0,0 +1,11 @@
+SUMMARY = "XML bomb protection for Python stdlib modules"
+DESCRIPTION = "Python package with modified subclasses of all stdlib XML \
+parsers that prevent any potentially malicious operation."
+
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=056fea6a4b395a24d0d278bf5c80249e"
+
+SRC_URI[md5sum] = "a59741f675c4cba649de40a99f732897"
+SRC_URI[sha256sum] = "f684034d135af4c6cbb949b8a4d2ed61634515257a67299e5f940fbaa34377f5"
+
+inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-fasteners_0.15.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-fasteners_0.15.bb
new file mode 100644
index 000000000..8786a1484
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-fasteners_0.15.bb
@@ -0,0 +1,9 @@
+SUMMARY = "A python package that provides useful locks."
+HOMEPAGE = "https://github.com/harlowja/fasteners"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4476c4be31402271e101d9a4a3430d52"
+
+SRC_URI[md5sum] = "440f8ab461c8fed941355860d8669556"
+SRC_URI[sha256sum] = "3a176da6b70df9bb88498e1a18a9e4a8579ed5b9141207762368a1017bf8f5ef"
+
+inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.3.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
new file mode 100644
index 000000000..8feb6daa3
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-networkx_2.3.bb
@@ -0,0 +1,8 @@
+require python-networkx.inc
+
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b68290ee1026b204170a23bbdb27a4fd"
+
+SRC_URI[md5sum] = "320d3f6c7872732baa63cedafddadea9"
+SRC_URI[sha256sum] = "8311ddef63cf5c5c5e7c1d0212dd141d9a1fe3f474915281b73597ed5f1d4e3d"
+
+inherit setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-python-vlc_3.0.7110.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-python-vlc_3.0.7110.bb
new file mode 100644
index 000000000..be63fed02
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-python-vlc_3.0.7110.bb
@@ -0,0 +1,9 @@
+SUMMARY = "This module provides ctypes-based bindings for the native libvlc API of the VLC video player."
+HOMEPAGE = "wiki.videolan.org/PythonBinding"
+LICENSE = "LGPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[md5sum] = "e128abf7115d6513582bd460c0e74485"
+SRC_URI[sha256sum] = "821bca0dbe08fbff97a65e56ff2318ad7d499330876579c39f01f3fb38c7b679"
+
+inherit pypi setuptools3
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
new file mode 100644
index 000000000..b94929d8c
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-requests-futures_0.9.5.bb
@@ -0,0 +1,14 @@
+SUMMARY = "Small add-on for the python requests http library. Makes use of python 3.2’s concurrent.futures or the backport for prior versions of python."
+HOMEPAGE = "https://github.com/ross/requests-futures"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e1e50798d0afe0e1f87594c6619a2fa5"
+
+SRC_URI[md5sum] = "e20dc6f063c70888a7f8225e349b6682"
+SRC_URI[sha256sum] = "33aa8a3b7892850701707d7e094b1e1ce7c4f7a36ff2a1dcc2da4e01a1a00f7e"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ python3-requests \
+"
+
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlrunner_1.7.7.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlrunner_1.7.7.bb
new file mode 100644
index 000000000..7e7b5235e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-xmlrunner_1.7.7.bb
@@ -0,0 +1,9 @@
+SUMMARY = "unittest-based test runner with Ant/JUnit like XML reporting"
+HOMEPAGE = "https://github.com/pycontribs/xmlrunner"
+LICENSE = "LGPL-3.0"
+LIC_FILES_CHKSUM = "file://PKG-INFO;md5=fa964f202b6ae067ed5828fe43c77c1a"
+
+SRC_URI[md5sum] = "7b0b152ed2d278516aedbc0cac22dfb3"
+SRC_URI[sha256sum] = "5a6113d049eca7646111ee657266966e5bbfb0b5ceb2e83ee0772e16d7110f39"
+
+inherit pypi setuptools3