summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-25 15:16:16 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-25 15:16:16 +0300
commit072e2389fd357e01fb3b4c5522bb9ff8f62da256 (patch)
treeb056a91dd47a7490e12d6e614048bcac93a1e448 /meta-openembedded/meta-python
parentdf48a130f3ebd4c73a8738a4047557f3238ced0f (diff)
downloadopenbmc-072e2389fd357e01fb3b4c5522bb9ff8f62da256.tar.xz
meta-openembedded: subtree update:b315c1a024..466fd78ac6
Anuj Mittal (1): python3-test-generator: add recipe Khem Raj (1): mongodb: Fix build on musl/aarch64 Zang Ruochen (2): fio: upgrade 3.15 -> 3.16 protobuf: upgrade 3.9.1 -> 3.9.2 Change-Id: I05a56fd5ecc017abc350bced6071680a58ccb8dc Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
new file mode 100644
index 000000000..14943a4bd
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-test-generator_0.1.2.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Generator is a helper for generating test methods for nose while still using unittest."
+DESCRIPTION = "Python package with modified subclasses of all stdlib XML \
+parsers that prevent any potentially malicious operation."
+
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=041a2bff595d40ccb4b36356f89dab00"
+
+SRC_URI[md5sum] = "6c69e73ba5b4b3ed62f7bcda071c64f1"
+SRC_URI[sha256sum] = "ad5925c814bfe79497b43df096e3bb52c166d1577f7aff160137301676232f4a"
+
+inherit pypi setuptools3
+
+DEPENDS += "python3-nose-native"
+
+RDEPENDS_${PN} += "python3-six"