summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:48 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-09-27 15:23:52 +0300
commit779d0acafa041a9df8ff46c614778538ab68acbd (patch)
tree39df5c7c2c0040c667131b35e01fa2e674cb78e7 /meta-openembedded/meta-python
parent9856fce4c853303bacbe5464a24759daeeb34684 (diff)
downloadopenbmc-779d0acafa041a9df8ff46c614778538ab68acbd.tar.xz
meta-openembedded: subtree update:466fd78ac6..41fe46157c
Callaghan, Dan (2): firewalld: add UPSTREAM_CHECK_URI add new recipes for python-lrparsing, python3-lrparsing Khem Raj (2): mongodb: Remove non building arches from COMPATIBLE_HOST uim: Fix cross-builds Martin Jansa (1): libmicrohttpd: backport the fix for building with older gnutls Oleksandr Kravchuk (4): libyui: update to 3.6.0 libyui-ncurses: udpate to 2.52.0 sanlock: update to 3.6.0 tesseract-lang: update to 4.0.0 Randy MacLeod (1): crash: update from 7.2.6 to 7.2.7 Robert Yang (8): python-asn1crypto: extend to nativesdk python-incremental: Drop broken nativesdk fuse: Fix installed-vs-shipped for nativesdk keyutils: Fix installed-vs-shipped for nativesdk libnet-ssleay-perl: Drop broken native libnet-dns-sec-perl: Drop broken native iperf3: Drop broken native spice: Drop broken native Trevor Gamblin (1): haveged: upgrade v1.9.4 -> v1.9.6 Zang Ruochen (5): xterm: upgrade 348 -> 349 python-cmd2: upgrade 0.9.16 -> 0.9.17 python-protobuf: upgrade 3.9.1 -> 3.9.2 python-alembic: upgrade 1.2.0 -> 1.2.1 python-paste: upgrade 3.2.0 -> 3.2.1 Change-Id: I4491ea47f5e54f4f3843a77c720d0a89304c36a5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-alembic.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-asn1crypto.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.17.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-incremental.inc2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing.inc16
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing_1.0.16.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb)4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc4
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.1.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.0.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.17.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb)0
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-lrparsing_1.0.16.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb (renamed from meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb)0
15 files changed, 30 insertions, 10 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-alembic.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-alembic.inc
index 8c917e310..fa178ce08 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-alembic.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-alembic.inc
@@ -2,8 +2,8 @@ DESCRIPTION = "A database migration tool for SQLAlchemy"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=28aaf14a6592d14dbfb2f4abd597aa27"
-SRC_URI[md5sum] = "7cdba960544ecb59fd74e6433d82036c"
-SRC_URI[sha256sum] = "5609afbb2ab142a991b15ae436347c475f8a517f1610f2fd1b09cdca7c311f3f"
+SRC_URI[md5sum] = "6fe272274fce2641b93998ef9b702b76"
+SRC_URI[sha256sum] = "9f907d7e8b286a1cfb22db9084f9ce4fde7ad7956bb496dc7c952e10ac90e36a"
PYPI_PACKAGE = "alembic"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.1.bb
index efcb2b1de..efcb2b1de 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-alembic_1.2.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-asn1crypto.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-asn1crypto.inc
index f1f0a3c51..e85ce9a91 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-asn1crypto.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-asn1crypto.inc
@@ -20,4 +20,4 @@ RDEPENDS_${PN}_class-target += " \
${PYTHON_PN}-netclient \
"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc
index 1a0be778b..3afa93adb 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2.inc
@@ -3,8 +3,8 @@ HOMEPAGE = "http://packages.python.org/cmd2/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=01aeabea7ae1529a8e4b674b7107d6bc"
-SRC_URI[md5sum] = "df35bb2dca8f5e1f6090e1f0aa02960a"
-SRC_URI[sha256sum] = "4b78379d53aff811d1deac720bbe71661769822a5fb2d830cd730656d180fb3d"
+SRC_URI[md5sum] = "c030c7364422609d16028fe1ea023bfe"
+SRC_URI[sha256sum] = "77bea602eb3b553a573188fa9514234bb1e44269d830a0ef8c4357f47aa9e46a"
inherit pypi
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.17.bb
index 17b6ae285..17b6ae285 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-cmd2_0.9.17.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-incremental.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-incremental.inc
index b63fac979..ef5e903fb 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-incremental.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-incremental.inc
@@ -17,4 +17,4 @@ RDEPENDS_${PN} += " \
# prevent a circular dependency. The build apparently does not use the part of
# python-incremental which uses python-twisted, so this hack is OK.
RDEPENDS_${PYTHON_PN}-incremental-native_remove = "${PYTHON_PN}-twisted-native"
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing.inc
new file mode 100644
index 000000000..d125151cd
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing.inc
@@ -0,0 +1,16 @@
+SUMMARY = "Python LR parsing library"
+SECTION = "devel/python"
+LICENSE = "AGPL-3.0"
+LIC_FILES_CHKSUM = "file://agpl-3.0.txt;md5=73f1eb20517c55bf9493b7dd6e480788"
+
+HOMEPAGE = "http://lrparsing.sourceforge.net/"
+BUGTRACKER = "https://sourceforge.net/p/lrparsing/tickets/"
+UPSTREAM_CHECK_URI = "https://sourceforge.net/projects/lrparsing/files/"
+UPSTREAM_CHECK_REGEX = "lrparsing-(?P<pver>\d+(\.\d+)+)"
+SRC_URI = "${SOURCEFORGE_MIRROR}/lrparsing/lrparsing-${PV}.tar.gz"
+SRC_URI[md5sum] = "34357d69bce87654d792cd8f02d148b2"
+SRC_URI[sha256sum] = "b45afda44001dc5ba632934f74c043d40cce653f1a7526cfbcb68f6be055b8d7"
+
+S = "${WORKDIR}/lrparsing-${PV}"
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing_1.0.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing_1.0.16.bb
new file mode 100644
index 000000000..2cfe3012e
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-lrparsing_1.0.16.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-lrparsing.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.1.bb
index 92a97d1e0..6c78598a4 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-paste_3.2.1.bb
@@ -5,8 +5,8 @@ RDEPENDS_${PN} = "python-six"
LIC_FILES_CHKSUM = "file://docs/license.txt;md5=1798f29d55080c60365e6283cb49779c"
-SRC_URI[md5sum] = "9225991c1c37a81e0aaac2fb046f3602"
-SRC_URI[sha256sum] = "2153da2f1b09a69bce7633d7e3f9aaa802572e85f9ac1ed09ad93ef8599d31b6"
+SRC_URI[md5sum] = "4ec8ac6032270daf91ff9621bda019d0"
+SRC_URI[sha256sum] = "3d9c9e96a8408777b01976dfce900049e9e8c970e02198534f2c8c1b2cca5dee"
PYPI_PACKAGE = "Paste"
inherit pypi setuptools
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
index 5058d4bd3..406131108 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf.inc
@@ -7,8 +7,8 @@ LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=19e8f490f9526b1de8
inherit pypi
-SRC_URI[md5sum] = "ca881f18795e024a2b935d5bae9b1ebe"
-SRC_URI[sha256sum] = "d831b047bd69becaf64019a47179eb22118a50dd008340655266a906c69c6417"
+SRC_URI[md5sum] = "d634666c898148e4565ac62f3ba4a2ca"
+SRC_URI[sha256sum] = "843f498e98ad1469ad54ecb4a7ccf48605a1c5d2bd26ae799c7a2cddab4a37ec"
# http://errors.yoctoproject.org/Errors/Details/184715/
# Can't find required file: ../src/google/protobuf/descriptor.proto
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.2.bb
index f04fc489f..f04fc489f 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python-protobuf_3.9.2.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.1.bb
index e248fe7ce..e248fe7ce 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-alembic_1.2.1.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.17.bb
index f5c5c7e1a..f5c5c7e1a 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.16.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-cmd2_0.9.17.bb
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-lrparsing_1.0.16.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-lrparsing_1.0.16.bb
new file mode 100644
index 000000000..21a80cde1
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-lrparsing_1.0.16.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-lrparsing.inc
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb
index 30ea34e90..30ea34e90 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-protobuf_3.9.2.bb