summaryrefslogtreecommitdiff
path: root/meta-openembedded/meta-python
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-05-05 16:53:09 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-05-05 16:53:37 +0300
commite231d58c35aabcb38dcd6470d232a738291d90fe (patch)
treea3b91de30b49acb14882df2223e2edc255ab95aa /meta-openembedded/meta-python
parent82c905dc58a36aeae40b1b273a12f63fb1973cf4 (diff)
downloadopenbmc-e231d58c35aabcb38dcd6470d232a738291d90fe.tar.xz
meta-openembedded: subtree update:17fd382f34..679bb49126
Andreas Müller (9): gparted: upgrade 0.33.0 -> 1.1.0 gjs: 1.58.6 -> 1.58.7 nautilus: upgrade 3.34.2 -> 3.34.3 xfce4-whiskermenu-plugin: upgrade 2.4.3 -> 2.4.4 xfce4-panel: upgrade 4.14.3 -> 4.14.4 poppler: upgrade 0.86.1 -> 0.88.0 mutter: upgrade 3.34.5 -> 3.34.6 openvpn: upgrade 2.4.8 -> 2.4.9 file-roller: upgrade 3.32.4 -> 3.32.5 Honggyu Kim (1): uftrace: update commit hash to more robust version Khem Raj (6): luajit: Disable on rv32 abseil-cpp: Fix build on riscv32 rsyslog: Enable atomic builtins on rv32 python3-grpcio: Fix build with riscv32 waf: Add cross answers for riscv32 libnma: Fix build on riscv32 Mingli Yu (1): nss: enable uint128 support on mips64 Peter Kjellerstedt (2): samba: Remove the dependency on libbsd paho-mqtt-c: Update to the real 1.3.2, and correct the license Slater, Joseph (1): syslog-ng: change shebang to python3 Trevor Gamblin (2): python3-atomicwrites: add python3-misc to RDEPENDS python3-pysocks: add python3-logging to RDEPENDS zhengruoqin (4): python3-pytoml: Modify ptest output format python3-pytz: Modify ptest output format python3-scrypt: Modify ptest output format python3-serpent: Modify ptest output format Change-Id: I7f985b3e43196dfe5064a954a12411ab6debdb68 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-python')
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Fix-build-on-riscv32.patch65
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch13
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb1
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml/run-ptest2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-pytz/run-ptest2
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-scrypt/run-ptest3
-rw-r--r--meta-openembedded/meta-python/recipes-devtools/python/python3-serpent/run-ptest3
9 files changed, 84 insertions, 8 deletions
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb
index 04bbed707..e43bf0884 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-atomicwrites_1.3.0.bb
@@ -7,3 +7,5 @@ SRC_URI[md5sum] = "ce11f780a4ce0fce8a55d64494a88178"
SRC_URI[sha256sum] = "75a9445bac02d8d058d5e1fe689654ba5a6556a1dfd8ce6ec55a0ed79866cfa6"
inherit pypi setuptools3
+
+RDEPENDS_${PN} = "${PYTHON_PN}-misc"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Fix-build-on-riscv32.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Fix-build-on-riscv32.patch
new file mode 100644
index 000000000..920fc1169
--- /dev/null
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/0001-Fix-build-on-riscv32.patch
@@ -0,0 +1,65 @@
+From 04e28fdda03b545a0f7b446a784ec2fa7249cbb8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Wed, 29 Apr 2020 15:37:40 -0700
+Subject: [PATCH] Fix build on riscv32
+
+Define __NR_mmap in terms of __NR_mmap2 and __NR_futex interms of
+__NR_futex_time64 for rv32, since there calls dont exist for rv32
+
+Also recognise rv32 as a new 32bit platform
+
+Upstream-Status: Submitted [https://github.com/abseil/abseil-cpp/pull/675]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ absl/base/internal/direct_mmap.h | 5 +++++
+ absl/base/internal/spinlock_linux.inc | 4 ++++
+ absl/synchronization/internal/waiter.cc | 4 ++++
+ 3 files changed, 13 insertions(+)
+
+--- a/third_party/abseil-cpp/absl/base/internal/direct_mmap.h
++++ b/third_party/abseil-cpp/absl/base/internal/direct_mmap.h
+@@ -26,6 +26,10 @@
+
+ #ifdef __linux__
+
++#if !defined(__NR_mmap) && defined(__riscv) && __riscv_xlen == 32
++# define __NR_mmap __NR_mmap2
++#endif
++
+ #include <sys/types.h>
+ #ifdef __BIONIC__
+ #include <sys/syscall.h>
+@@ -72,6 +76,7 @@ inline void* DirectMmap(void* start, siz
+ #if defined(__i386__) || defined(__ARM_ARCH_3__) || defined(__ARM_EABI__) || \
+ (defined(__mips__) && _MIPS_SIM == _MIPS_SIM_ABI32) || \
+ (defined(__PPC__) && !defined(__PPC64__)) || \
++ (defined(__riscv) && __riscv_xlen == 32) || \
+ (defined(__s390__) && !defined(__s390x__))
+ // On these architectures, implement mmap with mmap2.
+ static int pagesize = 0;
+--- a/third_party/abseil-cpp/absl/base/internal/spinlock_linux.inc
++++ b/third_party/abseil-cpp/absl/base/internal/spinlock_linux.inc
+@@ -14,6 +14,10 @@
+ //
+ // This file is a Linux-specific part of spinlock_wait.cc
+
++#if !defined(__NR_futex) && defined(__riscv) && __riscv_xlen == 32
++# define __NR_futex __NR_futex_time64
++#endif
++
+ #include <linux/futex.h>
+ #include <sys/syscall.h>
+ #include <unistd.h>
+--- a/third_party/abseil-cpp/absl/synchronization/internal/waiter.cc
++++ b/third_party/abseil-cpp/absl/synchronization/internal/waiter.cc
+@@ -24,6 +24,10 @@
+ #include <unistd.h>
+ #endif
+
++#if !defined(__NR_futex) && defined(__riscv) && __riscv_xlen == 32
++# define __NR_futex __NR_futex_time64
++#endif
++
+ #ifdef __linux__
+ #include <linux/futex.h>
+ #include <sys/syscall.h>
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch
index b55d50bde..8c9ffa21b 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio/riscv64_support.patch
@@ -4,13 +4,18 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
--- a/third_party/boringssl/include/openssl/base.h
+++ b/third_party/boringssl/include/openssl/base.h
-@@ -108,6 +108,9 @@ extern "C" {
+@@ -108,6 +108,14 @@ extern "C" {
#elif defined(__mips__) && defined(__LP64__)
#define OPENSSL_64_BIT
#define OPENSSL_MIPS64
-+#elif defined(__riscv) && defined(__riscv_xlen)
-+#define OPENSSL_64_BIT
-+#define OPENSSL_RISCV64
++#elif defined(__riscv)
++# if (__riscv_xlen == 64)
++# define OPENSSL_64_BIT
++# define OPENSSL_RISCV64
++# elif(__riscv_xlen == 32)
++# define OPENSSL_32_BIT
++# define OPENSSL_RISCV32
++# endif
#elif defined(__pnacl__)
#define OPENSSL_32_BIT
#define OPENSSL_PNACL
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
index 83d367101..129bb35bc 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-grpcio_1.27.1.bb
@@ -9,6 +9,7 @@ DEPENDS += "${PYTHON_PN}-protobuf"
SRC_URI += "file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch"
SRC_URI_append_class-target = " file://ppc-boringssl-support.patch \
file://riscv64_support.patch \
+ file://0001-Fix-build-on-riscv32.patch \
"
SRC_URI[md5sum] = "ccaf4e7eb4f031d926fb80035d193b98"
SRC_URI[sha256sum] = "a899725d34769a498ecd3be154021c4368dd22bdc69473f6ec46779696f626c4"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb b/meta-openembedded/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
index e311904fc..d0db8a063 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pysocks_1.7.1.bb
@@ -12,6 +12,7 @@ inherit pypi setuptools3
RDEPENDS_${PN}_class-target += "\
${PYTHON_PN}-email \
${PYTHON_PN}-io \
+ ${PYTHON_PN}-logging \
${PYTHON_PN}-netclient \
${PYTHON_PN}-shell \
"
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml/run-ptest b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml/run-ptest
index 5cec71169..b63c4de0d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml/run-ptest
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytoml/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz/run-ptest b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz/run-ptest
index 5cec71169..b63c4de0d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz/run-ptest
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-pytz/run-ptest
@@ -1,3 +1,3 @@
#!/bin/sh
-pytest
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-scrypt/run-ptest b/meta-openembedded/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
index 40c284799..b63c4de0d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-scrypt/run-ptest
@@ -1,2 +1,3 @@
#!/bin/sh
-pytest
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-openembedded/meta-python/recipes-devtools/python/python3-serpent/run-ptest b/meta-openembedded/meta-python/recipes-devtools/python/python3-serpent/run-ptest
index 40c284799..b63c4de0d 100644
--- a/meta-openembedded/meta-python/recipes-devtools/python/python3-serpent/run-ptest
+++ b/meta-openembedded/meta-python/recipes-devtools/python/python3-serpent/run-ptest
@@ -1,2 +1,3 @@
#!/bin/sh
-pytest
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'