summaryrefslogtreecommitdiff
path: root/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-23 04:40:54 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 19:39:42 +0300
commit194ff4f1f5d44b12e9cb06ddafa6adb20174a13c (patch)
tree823835cd29daf8901a31ac14c7e6534abf199be3 /meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
parent4feb727cd6b77a68bdaca63e121b378d814f5eaf (diff)
downloadopenbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.tar.xz
[Subtree] Bring openbmc machines to top level
The new subtree model brings the subtrees up from the openbmc-machines layer. Change-Id: I58a03ae1be374bc79ae1438e65e888375d12d0c0 Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/common/recipes-phosphor/host/op-proc-control.bb')
-rw-r--r--meta-openpower/common/recipes-phosphor/host/op-proc-control.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb b/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
new file mode 100644
index 000000000..a9c030bdc
--- /dev/null
+++ b/meta-openpower/common/recipes-phosphor/host/op-proc-control.bb
@@ -0,0 +1,26 @@
+SUMMARY = "OpenPower procedure control"
+DESCRIPTION = "Provides procedures that run against the host chipset"
+PR = "r1"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig pythonnative
+
+SRC_URI += "git://github.com/openbmc/openpower-proc-control"
+SRCREV = "6d83ddf7691fed618b8d9e871f608b8754e2134e"
+
+DEPENDS += " \
+ autoconf-archive-native \
+ phosphor-logging \
+ phosphor-dbus-interfaces \
+ openpower-dbus-interfaces \
+ "
+
+RDEPENDS_${PN} += " \
+ phosphor-logging \
+ phosphor-dbus-interfaces \
+ openpower-dbus-interfaces \
+ "