summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/ekb/ekb_git.bb
diff options
context:
space:
mode:
authorjmbills <jason.m.bills@intel.com>2021-08-03 01:45:08 +0300
committerGitHub <noreply@github.com>2021-08-03 01:45:08 +0300
commit10ad77d5bc86709d8ff7f95e7040e39f1c153903 (patch)
tree307cedb87f4c0a329740c55ac364ed489d1d8fc2 /meta-openpower/recipes-bsp/ekb/ekb_git.bb
parentc6b1c6ba7a01b7987d65d61c262c44c320193108 (diff)
parent67327ddc580cb9a85219a534844832a1682780d4 (diff)
downloadopenbmc-10ad77d5bc86709d8ff7f95e7040e39f1c153903.tar.xz
Merge pull request #69 from Intel-BMC/update2021-0.631-0.63
Update
Diffstat (limited to 'meta-openpower/recipes-bsp/ekb/ekb_git.bb')
-rw-r--r--meta-openpower/recipes-bsp/ekb/ekb_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ekb/ekb_git.bb b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
new file mode 100644
index 000000000..4ecf1f8d3
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ekb/ekb_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "To get required hardware procedure attribute xml files"
+DESCRIPTION = "Copy all the required hardware procedures attributes xml file \
+with respective directory structures"
+
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE_PROLOG;md5=d8e5f403c98fd80dcea90b9cc8cd083c"
+
+require ekb.inc
+
+SRC_URI = "${EKB_URI}"
+SRCREV = "${EKB_REV}"
+
+S = "${WORKDIR}/git"
+
+BBCLASSEXTEND = "native"
+
+do_install() {
+
+ mkdir -p ${D}${datadir}/${BPN}
+
+ # Copying all required hwp's attributes xml file with respective directory structures
+ (cd ${S} && cp --parents ${REQ_ATTRS_XMLS} ${D}${datadir}/${BPN})
+}