summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/ffs
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:30:50 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-05 00:28:29 +0300
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-bsp/ffs
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadopenbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.xz
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-bsp/ffs')
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs.inc17
-rw-r--r--meta-openpower/recipes-bsp/ffs/ffs_git.bb8
2 files changed, 25 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ffs/ffs.inc b/meta-openpower/recipes-bsp/ffs/ffs.inc
new file mode 100644
index 000000000..f144884aa
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ffs/ffs.inc
@@ -0,0 +1,17 @@
+SUMMARY = "Tools for manipulating FFS flash images."
+DESCRIPTION = "FFS is the FSP Flash File Structure which is also currently \
+used on OpenPOWER machines for the flash layout."
+
+HOMEPAGE = "https://github.com/open-power/ffs"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit autotools pkgconfig
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_BEFORE_PN += "${PN}-ecc ${PN}-deprecated"
+
+FILES_${PN}-ecc = "${bindir}/ecc"
+FILES_${PN}-deprecated = "${bindir}"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-openpower/recipes-bsp/ffs/ffs_git.bb b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
new file mode 100644
index 000000000..2340121bd
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ffs/ffs_git.bb
@@ -0,0 +1,8 @@
+require ffs.inc
+
+PV = "v0.1.0+git${SRCPV}"
+
+SRCREV = "3ec70fbc458e32eef0d0b1de79688b4dc48cbd57"
+SRC_URI += "git://github.com/open-power/ffs.git"
+
+S = "${WORKDIR}/git"