summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/skiboot
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 20:35:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commit8c6707f0dcab30d2c0d818b455b030b5d7e7091c (patch)
treee6d72dfc25e2769c7c6ea93c064af0970d8f3c7e /meta-openpower/recipes-bsp/skiboot
parentf3acf6db3a6e527a4c8347643924fbc33c65e237 (diff)
downloadopenbmc-8c6707f0dcab30d2c0d818b455b030b5d7e7091c.tar.xz
meta-openpower: prep for new override syntax
Change-Id: I5ca16c6fa7bc616bfa9bc41c4f86d32fd92b0287 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-bsp/skiboot')
-rw-r--r--meta-openpower/recipes-bsp/skiboot/gard_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/pflash_git.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/skiboot.inc6
3 files changed, 5 insertions, 5 deletions
diff --git a/meta-openpower/recipes-bsp/skiboot/gard_git.bb b/meta-openpower/recipes-bsp/skiboot/gard_git.bb
index 214e905ef..49d86602d 100644
--- a/meta-openpower/recipes-bsp/skiboot/gard_git.bb
+++ b/meta-openpower/recipes-bsp/skiboot/gard_git.bb
@@ -2,4 +2,4 @@ SUMMARY = "gard record tool for OpenPower"
DESCRIPTION = "gard record tool for OpenPower machines"
require skiboot.inc
-EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
+EXTRA_OEMAKE:append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
diff --git a/meta-openpower/recipes-bsp/skiboot/pflash_git.bb b/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
index 05aa2fcca..e30cad563 100644
--- a/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
+++ b/meta-openpower/recipes-bsp/skiboot/pflash_git.bb
@@ -2,7 +2,7 @@ SUMMARY = "pflash programmer for OpenPower"
DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
require skiboot.inc
-EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
+EXTRA_OEMAKE:append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
#TODO: openbmc/openbmc#1361 - Fix GNU_HASH warnings in pflash
TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openpower/recipes-bsp/skiboot/skiboot.inc b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
index 7140c6432..4f3791266 100644
--- a/meta-openpower/recipes-bsp/skiboot/skiboot.inc
+++ b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
@@ -3,7 +3,7 @@ LICENSE = "Apache-2.0"
SRC_URI += "git://github.com/open-power/skiboot.git;branch=skiboot-6.5.x"
-FILESEXTRAPATHS_prepend := "${THISDIR}/skiboot:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/skiboot:"
LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
@@ -27,6 +27,6 @@ do_install() {
}
# libflash.so is a SONAME and is strongly required in the production
-INSANE_SKIP_${PN}_append = "dev-so"
+INSANE_SKIP:${PN}:append = "dev-so"
FILES_SOLIBSDEV = ""
-FILES_${PN}_append = " ${libdir}/libflash.so"
+FILES:${PN}:append = " ${libdir}/libflash.so"