summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp/skiboot
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-31 13:30:50 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-05 00:28:29 +0300
commitd3f78932cf6b3063caceacdae9ddd6ca30d48786 (patch)
tree765de745d26798d7a37340d2851b86b57cda7eb8 /meta-openpower/recipes-bsp/skiboot
parentf1ade61b5994799a4cffca0c124b2ed36e640cbf (diff)
downloadopenbmc-d3f78932cf6b3063caceacdae9ddd6ca30d48786.tar.xz
meta-openpower: Move layer content from common/
Adopt a more conventional directory hierarchy. meta-openpower is still a _long_ way from suitable for hosting on yoctoproject.org but things like this don't help. (From meta-openpower rev: 2c8db5661cecd7e4cc20bcb96df76490e62cfb67) Change-Id: I415caaa28ec728f24e755ddb549012f24874fefe Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-bsp/skiboot')
-rw-r--r--meta-openpower/recipes-bsp/skiboot/gard.bb5
-rw-r--r--meta-openpower/recipes-bsp/skiboot/pflash.bb8
-rw-r--r--meta-openpower/recipes-bsp/skiboot/skiboot.inc27
3 files changed, 40 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/skiboot/gard.bb b/meta-openpower/recipes-bsp/skiboot/gard.bb
new file mode 100644
index 000000000..214e905ef
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/gard.bb
@@ -0,0 +1,5 @@
+SUMMARY = "gard record tool for OpenPower"
+DESCRIPTION = "gard record tool for OpenPower machines"
+
+require skiboot.inc
+EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} GARD_VERSION=${PV}"
diff --git a/meta-openpower/recipes-bsp/skiboot/pflash.bb b/meta-openpower/recipes-bsp/skiboot/pflash.bb
new file mode 100644
index 000000000..05aa2fcca
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/pflash.bb
@@ -0,0 +1,8 @@
+SUMMARY = "pflash programmer for OpenPower"
+DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
+
+require skiboot.inc
+EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
+
+#TODO: openbmc/openbmc#1361 - Fix GNU_HASH warnings in pflash
+TARGET_CC_ARCH += "${LDFLAGS}"
diff --git a/meta-openpower/recipes-bsp/skiboot/skiboot.inc b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
new file mode 100644
index 000000000..169b207b7
--- /dev/null
+++ b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
@@ -0,0 +1,27 @@
+HOMEPAGE = "https://github.com/open-power"
+LICENSE = "Apache-2.0"
+
+SRC_URI += "git://github.com/open-power/skiboot.git;nobranch=1"
+
+FILESEXTRAPATHS_append := "${THISDIR}/skiboot:"
+
+LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "452998f4be5973d8884e3db5aa362bf40e11467a"
+PV = "v6.1"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SKIBOOT_VERSION=${PV} V=1"
+
+SKIBOOT_SUBDIR ?= "external/${PN}"
+
+do_compile() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} all
+}
+
+# TODO: remove PREFIX=$prefix when updating to a version that has
+# http://patchwork.ozlabs.org/patch/923741/ is merged upstream
+do_install() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} install DESTDIR=${D} prefix=/usr PREFIX=$prefix
+}