summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-bsp
diff options
context:
space:
mode:
authorJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
committerJason M. Bills <jason.m.bills@linux.intel.com>2019-12-05 23:27:58 +0300
commitccd6cab15aedd223a42dfdb110ab2d71d8a87141 (patch)
tree2050b16c5978dbf1268ea0f1a65d15026ec25831 /meta-openpower/recipes-bsp
parent6f65bb40d3e8b7fe978698488c2ea93f077bfcd6 (diff)
parent6dbb316ab9052d4dbf158377e1ffe36f205d5477 (diff)
downloadopenbmc-ccd6cab15aedd223a42dfdb110ab2d71d8a87141.tar.xz
Merge branch 'master' of ssh://git-amr-1.devtools.intel.com:29418/openbmc-openbmc into update
Diffstat (limited to 'meta-openpower/recipes-bsp')
-rw-r--r--meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb19
-rw-r--r--meta-openpower/recipes-bsp/ecmd/croserver_git.bb36
-rw-r--r--meta-openpower/recipes-bsp/ecmd/files/croserver.service12
-rw-r--r--meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb2
-rw-r--r--meta-openpower/recipes-bsp/skiboot/skiboot.inc6
5 files changed, 72 insertions, 3 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb b/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb
new file mode 100644
index 000000000..21b397972
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "eCMD plugin with pdbg backend"
+DESCRIPTION = "The glue code necessary for pdbg to be used as an eCMD plugin"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit meson
+inherit pkgconfig
+
+SRC_URI = "git://github.com/open-power/ecmd-pdbg.git"
+SRCREV = "d955e0efe5a4e01af23448083d63cc8581a18b3e"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "pdbg zlib libyaml"
+
+FILES_${PN} += "${prefix}/help" \ No newline at end of file
diff --git a/meta-openpower/recipes-bsp/ecmd/croserver_git.bb b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
new file mode 100644
index 000000000..01005f8fa
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ecmd/croserver_git.bb
@@ -0,0 +1,36 @@
+SUMMARY = "eCMD"
+DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
+LICENSE= "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
+
+SRC_URI = "git://github.com/open-power/eCMD.git"
+SRCREV = "6c0348b12c95b3bd6e8d8003f9ff743d25400ae2"
+DEPENDS += "python-native zlib"
+
+SRC_URI += "file://croserver.service"
+
+S = "${WORKDIR}/git"
+
+# Add the hash style option here to Work around this warning:
+# "QA Issue: No GNU_HASH in the elf binary"
+#
+# The recipe cannot set LDFLAGS in the environment as it overrides the
+# internal settings.
+do_configure() {
+ LD="${CXX} -Wl,--hash-style=gnu" ${S}/config.py --without-swig --output-root ${B} --target obj --extensions "cmd cip" --build-verbose
+}
+
+do_compile() {
+ cd ${S}/dllNetwork/server
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
+
+ install -d ${D}${systemd_system_unitdir}
+ install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
+}
+
+FILES_${PN} += "${systemd_system_unitdir}/croserver.service"
diff --git a/meta-openpower/recipes-bsp/ecmd/files/croserver.service b/meta-openpower/recipes-bsp/ecmd/files/croserver.service
new file mode 100644
index 000000000..38d1fd2ff
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ecmd/files/croserver.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Cronus Server
+Documentation=https://github.com/open-power/eCMD/
+After=network.service
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/croserver
+Restart=on-failure
+ProtectHome=yes
+ProtectSystem=full
+RestrictAddressFamilies=AF_UNIX
diff --git a/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb b/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
index e1651ca5c..08f936d18 100644
--- a/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
+++ b/meta-openpower/recipes-bsp/pdbg/pdbg_2.4.bb
@@ -13,3 +13,5 @@ DEPENDS += "dtc-native"
S = "${WORKDIR}/git"
inherit autotools
+
+BBCLASSEXTEND = "native"
diff --git a/meta-openpower/recipes-bsp/skiboot/skiboot.inc b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
index 4f7ba6502..e7fbf4a7d 100644
--- a/meta-openpower/recipes-bsp/skiboot/skiboot.inc
+++ b/meta-openpower/recipes-bsp/skiboot/skiboot.inc
@@ -1,14 +1,14 @@
HOMEPAGE = "https://github.com/open-power"
LICENSE = "Apache-2.0"
-SRC_URI += "git://github.com/open-power/skiboot.git"
+SRC_URI += "git://github.com/open-power/skiboot.git;branch=skiboot-6.5.x"
FILESEXTRAPATHS_prepend := "${THISDIR}/skiboot:"
LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "54811997b6d02dacaf8dd0d61cadaf3786dbabb0"
-PV = "6.3.0+git${SRCPV}"
+SRCREV = "aff9301bb341b5387228e82036a7d72e519d8855"
+PV = "6.5.1+git${SRCPV}"
S = "${WORKDIR}/git"