summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 20:35:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commit8c6707f0dcab30d2c0d818b455b030b5d7e7091c (patch)
treee6d72dfc25e2769c7c6ea93c064af0970d8f3c7e /meta-openpower/recipes-phosphor/host
parentf3acf6db3a6e527a4c8347643924fbc33c65e237 (diff)
downloadopenbmc-8c6707f0dcab30d2c0d818b455b030b5d7e7091c.tar.xz
meta-openpower: prep for new override syntax
Change-Id: I5ca16c6fa7bc616bfa9bc41c4f86d32fd92b0287 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb10
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-cfam-override.bb6
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb8
6 files changed, 17 insertions, 17 deletions
diff --git a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
index 252773422..9f1828772 100644
--- a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
+++ b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
@@ -11,7 +11,7 @@ inherit autotools
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "pnorboot.service"
+SYSTEMD_SERVICE:${PN} += "pnorboot.service"
SRC_URI += "git://github.com/shenki/aspeed-lpc-control"
SRCREV = "af42b7ff01e71c0dd4c60214dd46ed487611f36d"
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index ebb3a2f77..83f3a3e03 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -7,7 +7,7 @@ inherit obmc-phosphor-systemd
inherit allarch
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
# For now, monitoring checkstop is the only usecase
OBMC_HOST_MONITOR_INSTANCES = "checkstop"
@@ -19,7 +19,7 @@ SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
# This package is not supplying the unit file and also this is not a native
# recipe since state-mgmt needs this package at runtime. Unsetting this below
# variable will let the build go through
-SYSTEMD_SERVICE_${PN} ?=""
+SYSTEMD_SERVICE:${PN} ?=""
# Install the override to set up a Conflicts relation
SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index e96fda5ac..8cedb62a5 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch
-RDEPENDS_${PN} += "op-proc-control"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "op-proc-control"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
@@ -99,7 +99,7 @@ pkg_postinst_${PN}() {
fi
}
-pkg_prerm_${PN}() {
+pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index f0dbf9b87..d21de5415 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -28,9 +28,9 @@ TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
+SYSTEMD_SERVICE:${PN} = "${TEMPLATE} ${INSTANCES}"
-SYSTEMD_SERVICE_${PN} += " \
+SYSTEMD_SERVICE:${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
op-stop-instructions@.service \
op-cfam-reset.service \
diff --git a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
index 769a1348d..0a189e8c6 100644
--- a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "op-proc-control"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
+RDEPENDS:${PN} += "op-proc-control"
S = "${WORKDIR}"
@@ -16,5 +16,5 @@ INSTFMT = "cfam_override@{0}.service"
TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 84dc7b14a..f735c0f82 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
-RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
+RPROVIDES:${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "op-proc-control \
+RDEPENDS:${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
@@ -21,5 +21,5 @@ INSTFMT = "start_host@{0}.service"
TGTFMT = "obmc-host-startmin@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"