summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-10-22 22:20:12 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-10-26 19:14:46 +0300
commit8c561eecb190655d51249c37286cc2c904dee7c0 (patch)
treea489df1bc284965502385f421d7d4f8464f1dfd9 /meta-openpower/recipes-phosphor/host
parent9657ed3a430000aa40231e97d8bcaeb2a88fb247 (diff)
downloadopenbmc-8c561eecb190655d51249c37286cc2c904dee7c0.tar.xz
treewide: clean up recipe checks in OBMC_MACHINE_FEATURES
OBMC_MACHINE_FEATURES is a variable that probably shouldn't even exist as all it does is provide a level of indirection to the real MACHINE_FEATURES (in phosphor-base.inc, OBMC_ is added to the base). There are a few recipes that have developed checks against OBMC_MACHINE_FEATURES for enabling recipe-level features when they should be checking the standard MACHINE_FEATURES variable. Clean up this recipe-level indirection. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Id437b93aa6c1de9a27726eea9b7e2c30e71ab3bf
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb26
2 files changed, 15 insertions, 15 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index 8cedb62a5..f3c63adad 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -48,7 +48,7 @@ pkg_postinst:${PN}() {
ln -s $TARGET $LINK
# Only install certain units if phal enabled
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
TARGET="../phal-reinit-devtree.service"
@@ -115,7 +115,7 @@ pkg_prerm:${PN}() {
rm $LINK
# Remove phal specific units if enabled
- if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
+ if [ "${@bb.utils.filter('MACHINE_FEATURES', 'phal', d)}" = phal ]; then
LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
rm $LINK
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 32a7d4778..92287f529 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -31,16 +31,16 @@ SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE:${PN} = "${TEMPLATE} ${INSTANCES}"
SYSTEMD_SERVICE:${PN} += " \
- xyz.openbmc_project.Control.Host.NMI.service \
- op-stop-instructions@.service \
- op-cfam-reset.service \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
- op-continue-mpreboot@.service \
- op-enter-mpreboot@.service \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-check@.service', '', d)} \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-clear.service', '', d)} \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-import-devtree@.service', '', d)} \
- ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-export-devtree@.service', '', d)} \
- "
+ op-cfam-reset.service \
+ op-continue-mpreboot@.service \
+ op-enter-mpreboot@.service \
+ op-stop-instructions@.service \
+ xyz.openbmc_project.Control.Host.NMI.service \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-reset-host-check@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'op-reset-host-clear.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-export-devtree@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-import-devtree@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'phal-reinit-devtree.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
+ ${@bb.utils.contains('MACHINE_FEATURES', 'phal', 'set-spi-mux.service', '', d)} \
+ "