summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/host
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2021-07-30 14:35:44 +0300
committerJayanth Othayoth <ojayanth@gmail.com>2021-08-09 18:03:41 +0300
commitad68ba3cd5b6f0674465cd05e67041a7a3a0fb31 (patch)
tree916f80dc732463c79af8a8667b181d1d070cc745 /meta-openpower/recipes-phosphor/host
parent36339c8bb80458e2e59b7c5ff87c8145ba2ac351 (diff)
downloadopenbmc-ad68ba3cd5b6f0674465cd05e67041a7a3a0fb31.tar.xz
meta-openpower: phal devtree data import service
Service to override r/w devtree attribute data to the newer version of devtree from older version. This is used in concurrent software update followed BMC reboot. This service will only run in the following condition: - Chassis power is on when the BMC comes out of reset - version bump to enable service back-end support Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: I352c60ba254cfcf50a2339224eab9fa418491cc7
Diffstat (limited to 'meta-openpower/recipes-phosphor/host')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb10
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb1
2 files changed, 10 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index c0132b80c..a30a3e46c 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -61,7 +61,12 @@ pkg_postinst_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-reset@0.target.requires/op-reset-host-check@0.service"
TARGET="../op-reset-host-check@.service"
ln -s $TARGET $LINK
- fi
+
+ mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ TARGET="../phal-import-devtree@.service"
+ ln -s $TARGET $LINK
+ fi
# If the memory preserving reboot feature is enabled, set it up
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" = mpreboot ]; then
@@ -111,6 +116,9 @@ pkg_prerm_${PN}() {
LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
rm $LINK
+
+ LINK="$D$systemd_system_unitdir/multi-user.target.wants/phal-import-devtree@0.service"
+ rm $LINK
fi
# Remove mpreboot specific units if enabled
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index fb9efc0e1..3fe33b6ed 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -41,4 +41,5 @@ SYSTEMD_SERVICE_${PN} += " \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'proc-pre-poweroff@.service', '', d)} \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-check@.service', '', d)} \
${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'op-reset-host-clear.service', '', d)} \
+ ${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'phal', 'phal-import-devtree@.service', '', d)} \
"