summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
diff options
context:
space:
mode:
authorZane Shelley <zshelle@us.ibm.com>2021-03-24 01:08:45 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2021-03-24 22:04:53 +0300
commit6714373f115a916f5bd61bd96824f06d657f7bb1 (patch)
tree6414585a2dbaa2822fc14c025ee13641e46a93cf /meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
parent9c37f1ee3d2f39c62fa73b201bce91bf36f78af9 (diff)
downloadopenbmc-6714373f115a916f5bd61bd96824f06d657f7bb1.tar.xz
Rearranged openpower-hw-diags recipe for clarity
This file was a bit disorganized and was updated to follow the formula of other recipes. Change-Id: Iddccddd5c463f08540fc61051bf4a67a577a0d89 Signed-off-by: Zane Shelley <zshelle@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb24
1 files changed, 15 insertions, 9 deletions
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index fdcff05f1..94cae40ec 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -1,22 +1,28 @@
-inherit meson systemd
+HOMEPAGE = "https://github.com/openbmc/openpower-hw-diags"
+SUMMARY = "Hardware Diagnostics for POWER Systems"
+
+DESCRIPTION = \
+ "In the event of a system fatal error reported by the internal system \
+ hardware (processor chips, memory chips, I/O chips, system memory, etc.), \
+ POWER Systems have the ability to diagnose the root cause of the failure \
+ and perform any service action needed to avoid repeated system failures."
-SUMMARY = "ATTN and HwDiags Support"
-DESCRIPTION = "Attention Handler and Hardware Diagnostics"
+PV = "0.1+git${SRCPV}"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
+inherit meson systemd
-SYSTEMD_SERVICE_${PN} = "attn_handler.service"
-PV = "0.1+git${SRCPV}"
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/openbmc/openpower-hw-diags"
SRCREV = "0b8368cb0aa251032eb18b5c938d009e27f0b152"
-S = "${WORKDIR}/git"
+SYSTEMD_SERVICE_${PN} = "attn_handler.service"
+FILES_${PN} += "${UNITDIR}/attn_handler.service"
DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
nlohmann-json"
-FILES_${PN} += "${UNITDIR}/attn_handler.service"
-
# This is required so that libhei is installed with the chip data files.
RDEPENDS_${PN} += "openpower-libhei"