summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
diff options
context:
space:
mode:
authorAlexander Filippov <a.filippov@yadro.com>2019-05-22 11:07:30 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-04 22:15:26 +0300
commit89bd384d4518e0d45bf7e103a789c6638c2fc22d (patch)
treec1ea2f519ab298c3e1b8b3e985f4c0d20e216935 /meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
parentd2e7538ef9e4fae2bf6f801f1c7f49411579bf7e (diff)
downloadopenbmc-89bd384d4518e0d45bf7e103a789c6638c2fc22d.tar.xz
meta-openpower: Set unique BMC hostname
To prevent hostnames conflicts this service appends to the default hostname a Serial Number retrieved from Inventory Manager. This operation is executed only at the first boot or after a factory reset. This will be skipped if hostname is manually configured to a non default value. (From meta-openpower rev: 55281dffb43c4c59a5fce24727627fa3de1498fe) Change-Id: I9c3aa7c19cf595a599baab71b2af49defb4b8c76 Signed-off-by: Alexander Filippov <a.filippov@yadro.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb')
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
new file mode 100644
index 000000000..1e9fdd66f
--- /dev/null
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Init BMC Hostname"
+DESCRIPTION = "Setup BMC Unique hostname"
+PR = "r1"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${OPENPOWERBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit allarch systemd
+
+RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+
+SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
+
+SRC_URI = "file://${PN}.sh file://${PN}.service"
+
+S = "${WORKDIR}"
+do_install() {
+ sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
+ install -d ${D}${bindir} ${D}${systemd_system_unitdir}
+ install ${PN}.sh ${D}${bindir}/
+ install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
+}
+