summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-03-31 21:47:05 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-03 00:14:03 +0300
commit109ae01dcb1f1fe0b752ccbea44ebebfe3d7ff04 (patch)
treec6c181d654beb96903d481ee30beb38d4e5fa201 /meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
parent55bd449938f8d450e9e186c5ef83bd4464e61361 (diff)
downloadopenbmc-109ae01dcb1f1fe0b752ccbea44ebebfe3d7ff04.tar.xz
op-occ-start/stop should not impact host targets
There have been some situations where things get so messed up that starting or stopping the occ monitoring on the BMC will fail. When this happens, the systemd target, obmc-host-start/stop can not complete. This really should be a wants relationship vs. a requires so that the targets can continue to start/stop the host. The service is not required to start/stop the host. (From meta-openpower rev: fe1136ab98b70c016720a4bd489d90d8feac17a0) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I99f858b611ba58d9f66773d36b06a07f84c0dbfb Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index aaab247f7..0f90160e6 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -50,11 +50,11 @@ OCC_DISABLE = "disable"
HOST_START = "startmin"
HOST_STOP = "stop"
-# Ensure host-stop and host-startmin targets require needed occ states
+# Ensure host-stop and host-startmin targets wants needed occ states
OCC_TMPL = "op-occ-{0}@.service"
HOST_TGTFMT = "obmc-host-{1}@{2}.target"
OCC_INSTFMT = "op-occ-{0}@{2}.service"
-HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.requires/${OCC_INSTFMT}"
+HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.wants/${OCC_INSTFMT}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"