summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
diff options
context:
space:
mode:
authorEddie James <eajames@linux.ibm.com>2020-03-05 18:28:18 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-03-18 05:44:44 +0300
commit64e281927e712df7bf6587cc04946e252a3749ee (patch)
treed3f3b4281773fcb42fe0f85f8297273bea823e40 /meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
parent8dfa78d9574c1be8b64cf0992a6a8cc591b22553 (diff)
downloadopenbmc-64e281927e712df7bf6587cc04946e252a3749ee.tar.xz
openpower-occ-control: Fix missing depends
The repo runs python to generate code or validate config, which requires python and the dependent python packages. Previously that happens to be satisfied by sdbusplus's RDEPENDS. If sdbusplus is changed to use python3, this repo fails to built because it lacks the dependency. See details in https://lists.ozlabs.org/pipermail/openbmc/2020-February/020771.html This commit fixes the depends by adding the required python and python packages so that it builds fine. (From meta-openpower rev: 344718b8b4dda75d47f89e72fb9b1372039ec6eb) Signed-off-by: Eddie James <eajames@linux.ibm.com> Change-Id: Ib744c2da0d42a12180c345a11086cba738880b42 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index cc0b56c64..b76894dac 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -31,6 +31,10 @@ DEPENDS += " \
phosphor-dbus-interfaces \
autoconf-archive-native \
systemd \
+ ${PYTHON_PN}-native \
+ ${PYTHON_PN}-pyyaml-native \
+ ${PYTHON_PN}-setuptools-native \
+ ${PYTHON_PN}-mako-native \
"
RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"