summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2020-02-10 17:19:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2020-02-13 21:35:48 +0300
commit5c45985a19ff6037d2bd0f26eff88215fe9b5cc2 (patch)
treecfd6477926ed12f0fafd4480710ddc821eab9024 /meta-openpower/recipes-phosphor
parent051165cc9ee84c42e0aa40a0e9a230c7b90abfff (diff)
downloadopenbmc-5c45985a19ff6037d2bd0f26eff88215fe9b5cc2.tar.xz
obmc-targets moved to phosphor-state-manager
The systemd targets provided by obmc-targets have been moved to the phosphor-state-manager repo. Interestingly enough, this dependency is not needed to get things to compile so there does not seem to be a co-req needed between this and the change that moves the targets to phosphor-state-manager. The target move is in the following commit: https://gerrit.openbmc-project.xyz/c/openbmc/meta-phosphor/+/28444 (From meta-openpower rev: 72aea7005606fa2eb64b05c3120f666346016cee) Signed-off-by: Andrew Geissler <geissonator@yahoo.com> Change-Id: I6a93b8ba4b5f96283e36656fdfc5f2520948e828 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 21d44381d..33ebb4676 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -32,10 +32,11 @@ DEPENDS += " \
phosphor-dbus-interfaces \
openpower-dbus-interfaces-native \
autoconf-archive-native \
- obmc-targets \
systemd \
"
+RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+
EXTRA_OECONF = " \
YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
@@ -70,17 +71,18 @@ S = "${WORKDIR}/git"
# Remove packages not required for native build
DEPENDS_remove_class-native = " \
phosphor-logging \
- obmc-targets \
systemd \
virtual/${PN}-config-native \
"
+RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
+
# Remove packages not required for native SDK build
DEPENDS_remove_class-nativesdk = " \
phosphor-logging \
- obmc-targets \
systemd \
virtual/${PN}-config-native \
"
+RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"
@@ -98,4 +100,3 @@ PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
PACKAGECONFIG_remove_class-target = "install_error_yaml"
BBCLASSEXTEND += "native nativesdk"
-