summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2020-07-16 05:42:04 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-07-18 21:32:53 +0300
commitb0e852292618fbde4eba8a3e3424ccd5a0366437 (patch)
tree206fe61bd4345192cb4b277d8e69d0f42a1d019c /meta-openpower/recipes-phosphor
parentc7edaebddf2a2400e7ac8268b40ab6bed0d41db5 (diff)
downloadopenbmc-b0e852292618fbde4eba8a3e3424ccd5a0366437.tar.xz
openpower-software-manager: Add mmc support
Add support for the mmc configuration option based on the phosphor-mmc distro feature. (From meta-openpower rev: dc65d339226402e55a1c04f2092268fff88f0686) Change-Id: I344a357516ce4233fc4a3098a98670e80c78d139 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb16
1 files changed, 15 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index a0873b444..4306ff99c 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -11,15 +11,29 @@ LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig systemd
inherit obmc-phosphor-dbus-service
+# Static configuration. This is the default if no other layout is specified.
+inherit ${@bb.utils.contains_any('DISTRO_FEATURES', \
+ 'openpower-ubi-fs phosphor-mmc', \
+ '', \
+ 'openpower-software-manager-static', d)}
+
+# UBI layout
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-ubi-fs', \
'openpower-software-manager-ubi', \
- 'openpower-software-manager-static', d)}
+ '', d)}
+# eMMC layout
+inherit ${@bb.utils.contains('DISTRO_FEATURES', 'phosphor-mmc', \
+ 'openpower-software-manager-mmc', \
+ '', d)}
+
+# Virtual PNOR
inherit ${@bb.utils.contains('DISTRO_FEATURES', 'openpower-virtual-pnor', \
'openpower-software-manager-virtual-pnor', \
'', d)}
PACKAGECONFIG[verify_pnor_signature] = "--enable-verify_pnor_signature,--disable-verify_pnor_signature"
PACKAGECONFIG[ubifs_layout] = "--enable-ubifs_layout,--disable-ubifs_layout,,mtd-utils-ubifs"
+PACKAGECONFIG[mmc_layout] = "--enable-mmc_layout,--disable-mmc_layout"
PACKAGECONFIG[virtual_pnor] = "--enable-virtual_pnor,--disable-virtual_pnor"
EXTRA_OECONF += " \