summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2021-08-06 20:35:36 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-08-11 20:28:12 +0300
commit8c6707f0dcab30d2c0d818b455b030b5d7e7091c (patch)
treee6d72dfc25e2769c7c6ea93c064af0970d8f3c7e /meta-openpower/recipes-phosphor
parentf3acf6db3a6e527a4c8347643924fbc33c65e237 (diff)
downloadopenbmc-8c6707f0dcab30d2c0d818b455b030b5d7e7091c.tar.xz
meta-openpower: prep for new override syntax
Change-Id: I5ca16c6fa7bc616bfa9bc41c4f86d32fd92b0287 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com>
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb4
-rw-r--r--meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces-mapper-config-native.bb4
-rw-r--r--meta-openpower/recipes-phosphor/dbus/phosphor-mapper-config-native%.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc4
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend4
-rw-r--r--meta-openpower/recipes-phosphor/dump/phosphor-debug-errors-native.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend4
-rw-r--r--meta-openpower/recipes-phosphor/fsi/op-fsi.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb10
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-cfam-override.bb6
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb8
-rw-r--r--meta-openpower/recipes-phosphor/initfs/obmc-phosphor-initfs.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/interfaces/bmcweb_%.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb6
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb4
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb4
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb2
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb24
-rw-r--r--meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend4
-rw-r--r--meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb28
-rw-r--r--meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/webui/phosphor-webui_%.bbappend6
33 files changed, 89 insertions, 89 deletions
diff --git a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
index 39141bab8..6f8a60791 100644
--- a/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
+++ b/meta-openpower/recipes-phosphor/configuration/openpower-yaml-config.bb
@@ -25,11 +25,11 @@ do_install() {
${D}${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml
}
-FILES_${PN}-dev = " \
+FILES:${PN}-dev = " \
${datadir}/${BPN}/ipmi-fru-properties-mrw.yaml \
${datadir}/${BPN}/ipmi-hostboot-fru-mrw.yaml \
${datadir}/${BPN}/ipmi-hostboot-volatile-sensor-mrw.yaml \
${datadir}/${BPN}/ipmi-occ-active-sensor-mrw.yaml \
"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
diff --git a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces-mapper-config-native.bb b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces-mapper-config-native.bb
index e0b296fb9..67b09ea5c 100644
--- a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces-mapper-config-native.bb
+++ b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces-mapper-config-native.bb
@@ -8,5 +8,5 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit phosphor-mapper
inherit native
-PHOSPHOR_MAPPER_SERVICE_append = " org.open_power"
-PHOSPHOR_MAPPER_INTERFACE_append = " org.open_power"
+PHOSPHOR_MAPPER_SERVICE:append = " org.open_power"
+PHOSPHOR_MAPPER_INTERFACE:append = " org.open_power"
diff --git a/meta-openpower/recipes-phosphor/dbus/phosphor-mapper-config-native%.bbappend b/meta-openpower/recipes-phosphor/dbus/phosphor-mapper-config-native%.bbappend
index 04df9733b..4eb20e812 100644
--- a/meta-openpower/recipes-phosphor/dbus/phosphor-mapper-config-native%.bbappend
+++ b/meta-openpower/recipes-phosphor/dbus/phosphor-mapper-config-native%.bbappend
@@ -1 +1 @@
-PHOSPHOR_MAPPER_CONFIGS_append_df-openpower = " openpower-dbus-interfaces-mapper-config-native"
+PHOSPHOR_MAPPER_CONFIGS:append:df-openpower = " openpower-dbus-interfaces-mapper-config-native"
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
index a3b729ec7..f681ed498 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector-systemd-links.inc
@@ -1,4 +1,4 @@
-pkg_postinst_${PN}_append() {
+pkg_postinst:${PN}:append() {
mkdir -p $D$systemd_system_unitdir/obmc-host-crash@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-timeout@0.target.wants
@@ -20,7 +20,7 @@ pkg_postinst_${PN}_append() {
ln -s $TARGET $LINK
}
-pkg_prerm_${PN}_append() {
+pkg_prerm:${PN}:append() {
if [ "${@bb.utils.filter('DISTRO_FEATURES', 'mpreboot', d)}" != mpreboot ]; then
LINK="$D$systemd_system_unitdir/obmc-host-crash@0.target.wants/openpower-debug-collector-checkstop@0.service"
rm $LINK
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index 482aaaf9d..94fffaf77 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -23,11 +23,11 @@ S = "${WORKDIR}/git"
APPS = "checkstop watchdog"
DEBUG_TMPL = "openpower-debug-collector-{0}@.service"
-SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}"
+SYSTEMD_SERVICE:${PN} += "${@compose_list(d, 'DEBUG_TMPL', 'APPS')}"
# Do not depend on phosphor-logging for native build
-DEPENDS_remove_class-native = "phosphor-logging"
+DEPENDS:remove:class-native = "phosphor-logging"
# Do not depend on phosphor-logging for native SDK build
-DEPENDS_remove_class-nativesdk = "phosphor-logging"
+DEPENDS:remove:class-nativesdk = "phosphor-logging"
diff --git a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend b/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
index a4cb739e8..00b9eadfc 100644
--- a/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
+++ b/meta-openpower/recipes-phosphor/dump/phosphor-debug-collector_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://plugins.d/guard"
install_openpower_plugins() {
@@ -13,6 +13,6 @@ python link_openpower_plugins() {
}
DEBUG_COLLECTOR_INSTALL_POSTFUNCS ?= ""
-DEBUG_COLLECTOR_INSTALL_POSTFUNCS_df-openpower ?= "install_openpower_plugins link_openpower_plugins"
+DEBUG_COLLECTOR_INSTALL_POSTFUNCS:df-openpower ?= "install_openpower_plugins link_openpower_plugins"
do_install[postfuncs] += "${DEBUG_COLLECTOR_INSTALL_POSTFUNCS}"
diff --git a/meta-openpower/recipes-phosphor/dump/phosphor-debug-errors-native.bbappend b/meta-openpower/recipes-phosphor/dump/phosphor-debug-errors-native.bbappend
index 72d991c7e..4fc41d058 100644
--- a/meta-openpower/recipes-phosphor/dump/phosphor-debug-errors-native.bbappend
+++ b/meta-openpower/recipes-phosphor/dump/phosphor-debug-errors-native.bbappend
@@ -1 +1 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
diff --git a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
index 1c6df5a11..ee6f01303 100644
--- a/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
+++ b/meta-openpower/recipes-phosphor/flash/openpower-software-manager_git.bb
@@ -51,11 +51,11 @@ DEPENDS += " \
sdbusplus \
"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
virtual-obmc-image-manager \
"
-FILES_${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.conf"
+FILES:${PN} += "${datadir}/dbus-1/system.d/org.open_power.Software.Host.Updater.conf"
S = "${WORKDIR}/git"
@@ -65,6 +65,6 @@ SRCREV = "5dc5d6cc6796ef038c59e41297349a982c8dd296"
DBUS_SERVICE_${PN} += "org.open_power.Software.Host.Updater.service"
-SYSTEMD_SERVICE_${PN} += " \
+SYSTEMD_SERVICE:${PN} += " \
op-pnor-msl.service \
"
diff --git a/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index 4f2ea9853..5255be429 100644
--- a/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -1,4 +1,4 @@
-FILESEXTRAPATHS_prepend_df-openpower := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend:df-openpower := "${THISDIR}/${PN}:"
-SYSTEMD_OVERRIDE_${PN}-updater_append_df-openpower = \
+SYSTEMD_OVERRIDE_${PN}-updater:append:df-openpower = \
" software-bmc-updater.conf:xyz.openbmc_project.Software.BMC.Updater.service.d/software-bmc-updater.conf"
diff --git a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
index bedf65011..a76acb44c 100644
--- a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
+++ b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-RDEPENDS_${PN} += "op-proc-control"
+RDEPENDS:${PN} += "op-proc-control"
TGTFMT_CHASSIS = "obmc-chassis-poweron@{0}.target"
TGTFMT_HOST = "obmc-host-startmin@{0}.target"
@@ -16,7 +16,7 @@ INSTFMT_SCAN = "fsi-scan@{0}.service"
FMT_SCAN_CHASSIS = "../${TMPL_SCAN}:${TGTFMT_CHASSIS}.wants/${INSTFMT_SCAN}"
FMT_SCAN_HOST = "../${TMPL_SCAN}:${TGTFMT_HOST}.wants/${INSTFMT_SCAN}"
-SYSTEMD_SERVICE_${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
+SYSTEMD_SERVICE:${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_CHASSIS', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_HOST', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
index 252773422..9f1828772 100644
--- a/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
+++ b/meta-openpower/recipes-phosphor/host/aspeed-lpc-ctrl_git.bb
@@ -11,7 +11,7 @@ inherit autotools
S = "${WORKDIR}/git"
-SYSTEMD_SERVICE_${PN} += "pnorboot.service"
+SYSTEMD_SERVICE:${PN} += "pnorboot.service"
SRC_URI += "git://github.com/shenki/aspeed-lpc-control"
SRCREV = "af42b7ff01e71c0dd4c60214dd46ed487611f36d"
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index ebb3a2f77..83f3a3e03 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -7,7 +7,7 @@ inherit obmc-phosphor-systemd
inherit allarch
DEPENDS += "virtual/obmc-gpio-monitor"
-RDEPENDS_${PN} += "virtual/obmc-gpio-monitor"
+RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
# For now, monitoring checkstop is the only usecase
OBMC_HOST_MONITOR_INSTANCES = "checkstop"
@@ -19,7 +19,7 @@ SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
# This package is not supplying the unit file and also this is not a native
# recipe since state-mgmt needs this package at runtime. Unsetting this below
# variable will let the build go through
-SYSTEMD_SERVICE_${PN} ?=""
+SYSTEMD_SERVICE:${PN} ?=""
# Install the override to set up a Conflicts relation
SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
index e96fda5ac..8cedb62a5 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control-systemd-links.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch
-RDEPENDS_${PN} += "op-proc-control"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "op-proc-control"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
-pkg_postinst_${PN}() {
+pkg_postinst:${PN}() {
mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
@@ -99,7 +99,7 @@ pkg_postinst_${PN}() {
fi
}
-pkg_prerm_${PN}() {
+pkg_prerm:${PN}() {
LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
rm $LINK
LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index f0dbf9b87..d21de5415 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -28,9 +28,9 @@ TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
+SYSTEMD_SERVICE:${PN} = "${TEMPLATE} ${INSTANCES}"
-SYSTEMD_SERVICE_${PN} += " \
+SYSTEMD_SERVICE:${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
op-stop-instructions@.service \
op-cfam-reset.service \
diff --git a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
index 769a1348d..0a189e8c6 100644
--- a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
@@ -6,8 +6,8 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
-RDEPENDS_${PN} += "op-proc-control"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
+RDEPENDS:${PN} += "op-proc-control"
S = "${WORKDIR}"
@@ -16,5 +16,5 @@ INSTFMT = "cfam_override@{0}.service"
TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index 84dc7b14a..f735c0f82 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -6,12 +6,12 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit obmc-phosphor-systemd
-FILESEXTRAPATHS_prepend := "${THISDIR}/op-host-control:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/op-host-control:"
PROVIDES += 'virtual/obmc-host-ctl'
-RPROVIDES_${PN} += 'virtual-obmc-host-ctl'
+RPROVIDES:${PN} += 'virtual-obmc-host-ctl'
-RDEPENDS_${PN} += "op-proc-control \
+RDEPENDS:${PN} += "op-proc-control \
op-proc-control-systemd-links"
S = "${WORKDIR}"
@@ -21,5 +21,5 @@ INSTFMT = "start_host@{0}.service"
TGTFMT = "obmc-host-startmin@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
-SYSTEMD_SERVICE_${PN} += "${TMPL}"
+SYSTEMD_SERVICE:${PN} += "${TMPL}"
SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/initfs/obmc-phosphor-initfs.bbappend b/meta-openpower/recipes-phosphor/initfs/obmc-phosphor-initfs.bbappend
index bb8a87c12..253903d80 100644
--- a/meta-openpower/recipes-phosphor/initfs/obmc-phosphor-initfs.bbappend
+++ b/meta-openpower/recipes-phosphor/initfs/obmc-phosphor-initfs.bbappend
@@ -1 +1 @@
-RDEPENDS_${PN}_append_df-openpower = " cf-fsi-firmware"
+RDEPENDS:${PN}:append:df-openpower = " cf-fsi-firmware"
diff --git a/meta-openpower/recipes-phosphor/interfaces/bmcweb_%.bbappend b/meta-openpower/recipes-phosphor/interfaces/bmcweb_%.bbappend
index 1220c8efe..7390574f9 100644
--- a/meta-openpower/recipes-phosphor/interfaces/bmcweb_%.bbappend
+++ b/meta-openpower/recipes-phosphor/interfaces/bmcweb_%.bbappend
@@ -1,4 +1,4 @@
-EXTRA_OEMESON_append_df-openpower = " \
+EXTRA_OEMESON:append:df-openpower = " \
-Dredfish-dbus-log=enabled \
-Dhttp-body-limit=400 \
"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
index 1dfa048dd..c08bd8e27 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-host-ipmi-flash_git.bb
@@ -23,6 +23,6 @@ S = "${WORKDIR}/git"
SRC_URI += "git://github.com/openbmc/openpower-host-ipmi-flash"
SRCREV = "61e18614a64866026b5da05b11e51df2b8653bc4"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native_git.bb
index bdf669b13..6f3b79821 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem-error-native_git.bb
@@ -10,7 +10,7 @@ require openpower-ipmi-oem.inc
S = "${WORKDIR}/git"
-do_install_append() {
+do_install:append() {
SRC=${S}/org/open_power/OCC
DEST=${D}${yaml_dir}/org/open_power/OCC
install -d ${DEST}
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index f817dffa3..e47a5d576 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -31,6 +31,6 @@ EXTRA_OECONF = " \
S = "${WORKDIR}/git"
-FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
-FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
-FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
+FILES:${PN}:append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
+FILES:${PN}:append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
+FILES:${PN}-dev:append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
diff --git a/meta-openpower/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend b/meta-openpower/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend
index ad56a88cd..c584202be 100644
--- a/meta-openpower/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend
+++ b/meta-openpower/recipes-phosphor/ipmi/phosphor-ipmi-sensor-config-native.bbappend
@@ -1 +1 @@
-OBMC_IPMI_SENSORS_PROVIDERS_append_df-openpower = " openpower-ipmi-oem-sensor-inventory-mrw-native"
+OBMC_IPMI_SENSORS_PROVIDERS:append:df-openpower = " openpower-ipmi-oem-sensor-inventory-mrw-native"
diff --git a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
index 34c108d6f..2cf826c55 100644
--- a/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
+++ b/meta-openpower/recipes-phosphor/logging/openpower-hw-diags_git.bb
@@ -21,13 +21,13 @@ S = "${WORKDIR}/git"
inherit meson systemd
-SYSTEMD_SERVICE_${PN} = "attn_handler.service"
+SYSTEMD_SERVICE:${PN} = "attn_handler.service"
DEPENDS = "boost libgpiod pdbg phosphor-logging sdbusplus openpower-libhei \
nlohmann-json valijson"
# This is required so that libhei is installed with the chip data files.
-RDEPENDS_${PN} += "openpower-libhei"
+RDEPENDS:${PN} += "openpower-libhei"
# Conditionally pull in PHAL APIs, if available.
PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
index f3f7d34cf..20161bcdc 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch systemd
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils}"
-SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
+SYSTEMD_SERVICE:${PN} = "first-boot-set-hostname.service"
SRC_URI = "file://${BPN}.sh file://${BPN}.service"
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
index f67ddd464..eaa04dfef 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-mac_1.0.bb
@@ -6,9 +6,9 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5
inherit allarch systemd
-RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
+RDEPENDS:${PN} = "${VIRTUAL-RUNTIME_base-utils}"
-SYSTEMD_SERVICE_${PN} = "first-boot-set-mac@.service"
+SYSTEMD_SERVICE:${PN} = "first-boot-set-mac@.service"
SRC_URI = "file://${BPN}.sh file://${BPN}@.service"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
index db9ce5d5e..f546355e5 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control-config-mrw-native.bb
@@ -11,7 +11,7 @@ PROVIDES += "virtual/openpower-occ-control-config-native"
DEPENDS += "mrw-native mrw-perl-tools-native"
# Generate a YAML files based on MRW input
-do_install_append() {
+do_install:append() {
install -d ${YAML_DEST}/
${STAGING_BINDIR_NATIVE}/perl-native/perl \
${STAGING_BINDIR_NATIVE}/gen_occ_map.pl \
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 210b5fcc2..02237b008 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -13,15 +13,15 @@ inherit autotools \
require ${BPN}.inc
SRC_URI += "file://occ-active.sh"
-do_install_append() {
+do_install:append() {
install -d ${D}${bindir}
install -m 0755 ${WORKDIR}/occ-active.sh \
${D}${bindir}/occ-active.sh
}
DBUS_SERVICE_${PN} += "org.open_power.OCC.Control.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-enable@.service"
-SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-enable@.service"
+SYSTEMD_SERVICE:${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
@@ -37,13 +37,13 @@ DEPENDS += " \
${PYTHON_PN}-mako-native \
"
-RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN} += "phosphor-state-manager-obmc-targets"
EXTRA_OECONF = " \
YAML_PATH=${STAGING_DATADIR_NATIVE}/${PN} \
PS_DERATING_FACTOR=${POWER_SUPPLY_DERATING_FACTOR} \
"
-EXTRA_OECONF_append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
+EXTRA_OECONF:append = "${@bb.utils.contains('OBMC_MACHINE_FEATURES', 'i2c-occ', ' --enable-i2c-occ', '', d)}"
OCC_ENABLE = "enable"
OCC_DISABLE = "disable"
@@ -71,22 +71,22 @@ SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS'
S = "${WORKDIR}/git"
# Remove packages not required for native build
-DEPENDS_remove_class-native = " \
+DEPENDS:remove:class-native = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-native += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-native += "phosphor-state-manager-obmc-targets"
# Remove packages not required for native SDK build
-DEPENDS_remove_class-nativesdk = " \
+DEPENDS:remove:class-nativesdk = " \
phosphor-logging \
systemd \
sdbusplus \
virtual/${PN}-config-native \
"
-RDEPENDS_${PN}_remove_class-nativesdk += "phosphor-state-manager-obmc-targets"
+RDEPENDS:${PN}:remove:class-nativesdk += "phosphor-state-manager-obmc-targets"
# Provide a means to enable/disable install_error_yaml feature
PACKAGECONFIG ??= "install_error_yaml"
@@ -97,10 +97,10 @@ PACKAGECONFIG[install_error_yaml] = "\
"
# Enable install_error_yaml during native and native SDK build
-PACKAGECONFIG_add_class-native = "install_error_yaml"
-PACKAGECONFIG_add_class-nativesdk = "install_error_yaml"
+PACKAGECONFIG:add:class-native = "install_error_yaml"
+PACKAGECONFIG:add:class-nativesdk = "install_error_yaml"
# Disable install_error_yaml during target build
-PACKAGECONFIG_remove_class-target = "install_error_yaml"
+PACKAGECONFIG:remove:class-target = "install_error_yaml"
BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
index ae1dc8d43..fecba185a 100644
--- a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
+++ b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bbappend
@@ -1,8 +1,8 @@
# Add checkstop monitor as part of host state management package
# This will kick start a gpio monitor that will catch the
# host checkstop conditions and takes necessary actions
-RDEPENDS_${PN}-host-state-mgmt_append_df-openpower = " checkstop-monitor"
+RDEPENDS:${PN}-host-state-mgmt:append:df-openpower = " checkstop-monitor"
# Add openpower debug collector as a requirement for state-mgmt
# since it is used during checkstop handling.
-RDEPENDS_${PN}-host-state-mgmt_append_df-openpower = " openpower-debug-collector"
+RDEPENDS:${PN}-host-state-mgmt:append:df-openpower = " openpower-debug-collector"
diff --git a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bbappend b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bbappend
index 09b4200e2..a2f00069e 100644
--- a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bbappend
+++ b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-ipmid-providers.bbappend
@@ -2,6 +2,6 @@
# providers with whitelists that should not be ignored to
# conf/machine/openpower.inc
-VIRTUAL-RUNTIME_phosphor-ipmi-providers_append_df-openpower = " \
+VIRTUAL-RUNTIME_phosphor-ipmi-providers:append:df-openpower = " \
openpower-host-ipmi-flash \
"
diff --git a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bbappend b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bbappend
index 5ba7c47eb..313261f00 100644
--- a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bbappend
+++ b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-obmc-phosphor-debugtools.bbappend
@@ -1,4 +1,4 @@
-RDEPENDS_${PN}_append_df-openpower = " \
+RDEPENDS:${PN}:append:df-openpower = " \
pflash \
gard \
fsidbg \
diff --git a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
index db3967a44..890967f96 100644
--- a/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
+++ b/meta-openpower/recipes-phosphor/packagegroups/packagegroup-op-apps.bb
@@ -16,36 +16,36 @@ PROVIDES += "virtual/obmc-fan-mgmt"
PROVIDES += "virtual/obmc-flash-mgmt"
PROVIDES += "virtual/obmc-system-mgmt"
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
+RPROVIDES:${PN}-chassis += "virtual-obmc-chassis-mgmt"
+RPROVIDES:${PN}-fans += "virtual-obmc-fan-mgmt"
+RPROVIDES:${PN}-flash += "virtual-obmc-flash-mgmt"
+RPROVIDES:${PN}-system += "virtual-obmc-system-mgmt"
-SUMMARY_${PN}-chassis = "OpenPOWER Chassis"
-RDEPENDS_${PN}-chassis = " \
+SUMMARY:${PN}-chassis = "OpenPOWER Chassis"
+RDEPENDS:${PN}-chassis = " \
obmc-phosphor-buttons-signals \
obmc-phosphor-buttons-handler \
obmc-op-control-power \
obmc-host-failure-reboots \
"
#Pull in obmc-fsi on all P9 OpenPOWER systems
-RDEPENDS_${PN}-chassis += "${@bb.utils.contains('MACHINE_FEATURES', 'op-fsi', 'op-fsi', '', d)}"
+RDEPENDS:${PN}-chassis += "${@bb.utils.contains('MACHINE_FEATURES', 'op-fsi', 'op-fsi', '', d)}"
#Pull in p9-cfam-override on all P9 OpenPOWER systems
-RDEPENDS_${PN}-chassis += "${@bb.utils.contains('MACHINE_FEATURES', 'p9-cfam-override', 'p9-cfam-override', '', d)}"
+RDEPENDS:${PN}-chassis += "${@bb.utils.contains('MACHINE_FEATURES', 'p9-cfam-override', 'p9-cfam-override', '', d)}"
-SUMMARY_${PN}-fans = "OpenPOWER Fans"
-RDEPENDS_${PN}-fans = " \
+SUMMARY:${PN}-fans = "OpenPOWER Fans"
+RDEPENDS:${PN}-fans = " \
"
-SUMMARY_${PN}-flash = "OpenPOWER Flash"
+SUMMARY:${PN}-flash = "OpenPOWER Flash"
-RDEPENDS_${PN}-flash = " \
+RDEPENDS:${PN}-flash = " \
openpower-software-manager\
"
-SUMMARY_${PN}-system = "OpenPOWER System"
-RDEPENDS_${PN}-system = " \
+SUMMARY:${PN}-system = "OpenPOWER System"
+RDEPENDS:${PN}-system = " \
pdbg \
croserver \
"
diff --git a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
index da31ab906..f3b7d4d9f 100644
--- a/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
+++ b/meta-openpower/recipes-phosphor/vpd/openpower-fru-vpd_git.bb
@@ -23,7 +23,7 @@ DEPENDS += " \
autoconf-archive-native \
"
-SYSTEMD_SERVICE_${PN} += "op-vpd-parser.service"
+SYSTEMD_SERVICE:${PN} += "op-vpd-parser.service"
S = "${WORKDIR}/git"
@@ -33,7 +33,7 @@ EXTRA_OEMESON = " \
-DPROP_YAML=${STAGING_DIR_NATIVE}${properties_datadir}/out.yaml \
"
-do_install_append() {
+do_install:append() {
SRC=${STAGING_DATADIR_NATIVE}${inventory_datadir_name}
DEST=${D}${inventory_envdir}
install -d ${DEST}
diff --git a/meta-openpower/recipes-phosphor/webui/phosphor-webui_%.bbappend b/meta-openpower/recipes-phosphor/webui/phosphor-webui_%.bbappend
index fc087d7ed..b73090eb7 100644
--- a/meta-openpower/recipes-phosphor/webui/phosphor-webui_%.bbappend
+++ b/meta-openpower/recipes-phosphor/webui/phosphor-webui_%.bbappend
@@ -1,8 +1,8 @@
-FILESEXTRAPATHS_prepend := "${THISDIR}/${BPN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${BPN}:"
-SRC_URI_append_df-openpower = " file://config.json"
+SRC_URI:append:df-openpower = " file://config.json"
-do_configure_append_df-openpower() {
+do_configure:append:df-openpower() {
# Overwrite the config.json to turn off/on Web UI panels
# E.g. Turn off the Redfish Event Log Panel since openpower systems use
# the D-Bus Event Log Panel