summaryrefslogtreecommitdiff
path: root/meta-openpower/recipes-phosphor
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2021-09-02 00:17:33 +0300
committerPatrick Williams <patrick@stwcx.xyz>2021-09-02 16:19:25 +0300
commite83c22094b7e4970c96bcee273ab08d05bbc0a30 (patch)
tree80cb87a34afb07b7d375b534bb5df68468c2b5a6 /meta-openpower/recipes-phosphor
parentd97cf9b9ef84cdad2f357164e36b76619e7dc379 (diff)
downloadopenbmc-e83c22094b7e4970c96bcee273ab08d05bbc0a30.tar.xz
meta-phosphor: change systemd.bbclass to match upstream override syntax
Upstream bbclasses changed to typically use the `:${PN}` override syntax, including the SYSTEMD_ variables. Change our systemd.bbclass to do the same for consistency and perform a tree-wide variable replacement. Spot checked by building bletchley and witherspoon and checking some of the SYSTEMD_LINK directives on installed packages under qemu. Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: I20a9dd809bff8af8759488734f80486c7228c6eb
Diffstat (limited to 'meta-openpower/recipes-phosphor')
-rw-r--r--meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend2
-rw-r--r--meta-openpower/recipes-phosphor/fsi/op-fsi.bb4
-rw-r--r--meta-openpower/recipes-phosphor/host/checkstop-monitor.bb6
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-cfam-override.bb2
-rw-r--r--meta-openpower/recipes-phosphor/host/p9-host-start.bb2
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb6
6 files changed, 11 insertions, 11 deletions
diff --git a/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend b/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
index 5255be429..9df8193be 100644
--- a/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
+++ b/meta-openpower/recipes-phosphor/flash/phosphor-software-manager_%.bbappend
@@ -1,4 +1,4 @@
FILESEXTRAPATHS:prepend:df-openpower := "${THISDIR}/${PN}:"
-SYSTEMD_OVERRIDE_${PN}-updater:append:df-openpower = \
+SYSTEMD_OVERRIDE:${PN}-updater:append:df-openpower = \
" software-bmc-updater.conf:xyz.openbmc_project.Software.BMC.Updater.service.d/software-bmc-updater.conf"
diff --git a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
index a76acb44c..05d07ddb8 100644
--- a/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
+++ b/meta-openpower/recipes-phosphor/fsi/op-fsi.bb
@@ -18,5 +18,5 @@ FMT_SCAN_HOST = "../${TMPL_SCAN}:${TGTFMT_HOST}.wants/${INSTFMT_SCAN}"
SYSTEMD_SERVICE:${PN} += "${TMPL_SCAN} fsi-enable.service fsi-disable.service"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_CHASSIS', 'OBMC_CHASSIS_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT_SCAN_HOST', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_SCAN_CHASSIS', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT_SCAN_HOST', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
index 83f3a3e03..9b1b1c4c5 100644
--- a/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
+++ b/meta-openpower/recipes-phosphor/host/checkstop-monitor.bb
@@ -14,7 +14,7 @@ OBMC_HOST_MONITOR_INSTANCES = "checkstop"
# Copies config file having arguments for monitoring host checkstop
# via GPIO assertion
-SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
+SYSTEMD_ENVIRONMENT_FILE:${PN} +="obmc/gpio/checkstop"
# This package is not supplying the unit file and also this is not a native
# recipe since state-mgmt needs this package at runtime. Unsetting this below
@@ -22,10 +22,10 @@ SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop"
SYSTEMD_SERVICE:${PN} ?=""
# Install the override to set up a Conflicts relation
-SYSTEMD_OVERRIDE_${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
+SYSTEMD_OVERRIDE:${PN} +="checkstop.conf:phosphor-gpio-monitor@checkstop.service.d/checkstop.conf"
STATES = "startmin"
GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{1}.service"
CHECKSTOP_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:obmc-host-{0}@{2}.target.wants/${GPIO_MONITOR_TGTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
index 0a189e8c6..d779785e4 100644
--- a/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-cfam-override.bb
@@ -17,4 +17,4 @@ TGTFMT = "obmc-chassis-poweron@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
SYSTEMD_SERVICE:${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/host/p9-host-start.bb b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
index f735c0f82..549bbe242 100644
--- a/meta-openpower/recipes-phosphor/host/p9-host-start.bb
+++ b/meta-openpower/recipes-phosphor/host/p9-host-start.bb
@@ -22,4 +22,4 @@ TGTFMT = "obmc-host-startmin@{0}.target"
FMT = "../${TMPL}:${TGTFMT}.requires/${INSTFMT}"
SYSTEMD_SERVICE:${PN} += "${TMPL}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 3903ef616..440829175 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -55,8 +55,8 @@ OCC_TMPL = "op-occ-{0}@.service"
HOST_TGTFMT = "obmc-host-{1}@{2}.target"
OCC_INSTFMT = "op-occ-{0}@{2}.service"
HOST_OCC_FMT = "../${OCC_TMPL}:${HOST_TGTFMT}.wants/${OCC_INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
-SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_ENABLE', 'HOST_START', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list_zip(d, 'HOST_OCC_FMT', 'OCC_DISABLE', 'HOST_STOP', 'OBMC_HOST_INSTANCES')}"
# Set the occ disable service to be executed on host error
HOST_ERROR_TARGETS = "crash timeout"
@@ -66,7 +66,7 @@ HOST_ERROR_TGTFMT = "obmc-host-{0}@{1}.target"
OCC_DISABLE_INSTFMT = "op-occ-disable@{1}.service"
HOST_ERROR_FMT = "../${OCC_DISABLE_TMPL}:${HOST_ERROR_TGTFMT}.wants/${OCC_DISABLE_INSTFMT}"
-SYSTEMD_LINK_${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
+SYSTEMD_LINK:${PN} += "${@compose_list(d, 'HOST_ERROR_FMT', 'HOST_ERROR_TARGETS', 'OBMC_HOST_INSTANCES')}"
S = "${WORKDIR}/git"