summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorLakshminarayana R. Kammath <lkammath@in.ibm.com>2019-06-11 20:37:25 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-07-26 22:59:21 +0300
commit4378a3fbfce82129ea6ca4ca44d6ee7a82057868 (patch)
treed89a3b4c31653b42e39e9cd76ce3f7c7ecf29668 /meta-openpower
parent5f160dc54541f44fa13749f669e648a45d7970f0 (diff)
downloadopenbmc-4378a3fbfce82129ea6ca4ca44d6ee7a82057868.tar.xz
meta-openpower: add a recipe for nmi service
1) Generic interface to initiate non maskable interrupt on host processors. 2) Bump up SRCREV for openpower-proc-control that enables NMI control (From meta-openpower rev: e915010db7ab5a874908f91ddd7fd985efbc64c5) Signed-off-by: Lakshminarayana R. Kammath <lkammath@in.ibm.com> Change-Id: Ibc7cb76bcde558618ed3624c022f0b016f022492 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 9e7fb54c6..592633bcf 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "b964c928156c2e71fe3bc9a2693b02cfbba5309c"
+SRCREV = "16ab00cb9383b17b8dd033a1cb300e2a013d55b1"
DEPENDS += " \
autoconf-archive-native \
@@ -19,9 +19,15 @@ DEPENDS += " \
phosphor-dbus-interfaces \
openpower-dbus-interfaces \
"
+RDEPENDS_${PN} += "pdbg"
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
+
+SYSTEMD_SERVICE_${PN} += " \
+ xyz.openbmc_project.Control.Host.NMI.service \
+ nmi.service \
+ "