summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorLakshminarayana R. Kammath <lkammath@in.ibm.com>2019-05-17 10:17:30 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-06-11 23:09:08 +0300
commita33d550ab04bdeb23732ecc9280f6d8a1996dc4b (patch)
tree0b1b5096ffc6e2ce71b218c2f7295454d1b3398e /meta-openpower
parenta7900a460a2bd716e55e839aa68381324896aac3 (diff)
downloadopenbmc-a33d550ab04bdeb23732ecc9280f6d8a1996dc4b.tar.xz
Add a recipe for hostboot-debug-tools.
This is a work in progress - at the moment this recipe doesn't do anything beyond ensuring the dependencies are installed. Tested : Verified. Perl executable and dependent libs available in debug tarball. (From meta-openpower rev: d252fd06a3bd282e4c80a6c961070acc2bfb3242) Signed-off-by: Lakshminarayana R. Kammath <lkammath@in.ibm.com> Change-Id: Iaee4127714bf9ccc5571bfea95d56f4d30add240 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb b/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb
new file mode 100644
index 000000000..f1265bda6
--- /dev/null
+++ b/meta-openpower/recipes-devtools/hostboot/hostboot-debug-tools.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Recipe for enabling hostboot-debug-tools"
+DESCRIPTION = "Support to enable running hostboot-debug-tools"
+LICENSE = "Apache-2.0"
+PR = "r1"
+
+inherit allarch
+
+RDEPENDS_${PN} = " \
+ perl perl-module-pod-text perl-module-lib \
+ perl-module-constant \
+ perl-module-errno perl-module-fcntl \
+ perl-module-file-basename perl-module-file-copy \
+ perl-module-file-find perl-module-file-glob \
+ perl-module-file-path perl-module-file-spec \
+ perl-module-file-temp perl-module-getopt-long \
+ perl-module-re perl-module-text-wrap \
+ perl-module-posix perl-module-bigint \
+ perl-module-integer \
+ "
+
+ALLOW_EMPTY_${PN} = "1"