summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2021-06-21 15:25:24 +0300
committerJayanth Othayoth <ojayanth@in.ibm.com>2021-06-30 16:39:49 +0300
commit0e656dde2411c07ab9680ec2de36ede0e3b9b8d7 (patch)
tree1e4f397946f18f89c1a0361e5c592be8de42c1ce /meta-openpower
parent15c59ca5aa82af1e1cf1ad444b19afef740af80c (diff)
downloadopenbmc-0e656dde2411c07ab9680ec2de36ede0e3b9b8d7.tar.xz
meta-openpower: Add guard support
guard repository provides the libraries and tools to create/list/delete guard records, which is stored in BMC flash space. This library currently supported OpenPOWER based systems guard format owned by hostboot. Repository: https://github.com/open-power/guard Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: I2b6e3be8492795be40a862fad6edbae3e8b205b5
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-bsp/guard/guard_git.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/guard/guard_git.bb b/meta-openpower/recipes-bsp/guard/guard_git.bb
new file mode 100644
index 000000000..0d5ff964f
--- /dev/null
+++ b/meta-openpower/recipes-bsp/guard/guard_git.bb
@@ -0,0 +1,19 @@
+HOMEPAGE = "https://github.com/open-power/guard"
+SUMMARY = "Guard the faulty components"
+DESCRIPTION = "Provide a way to guard the faulty component from the system"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+inherit meson
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git@github.com/open-power/guard;branch="main""
+SRCREV = "87b02b63b64b36a925bec42723d70e0531e93407"
+
+DEPENDS = "cli11"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}"
+PACKAGECONFIG[phal] = "-Ddevtree=enabled, -Ddevtree=disabled, pdata pdbg"