summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorAdriana Kobylak <anoo@us.ibm.com>2019-08-08 18:30:29 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-09 01:51:18 +0300
commitfc7299c7f7255c5f4e7162dd81326d3a71d29713 (patch)
tree7fc59c526827ff617b294c5185f1074cdb59191e /meta-openpower
parent88a7fe6ea8f34f0c1ed4d8efcbc497742c4585b1 (diff)
downloadopenbmc-fc7299c7f7255c5f4e7162dd81326d3a71d29713.tar.xz
meta-openpower: first-boot-set-hostname: use BPN
Avoid a new QA warning: SRC_URI uses PN not BPN [src-uri-bad] (From meta-openpower rev: b46a23a26760830e18f4813cbec8e143b9effd0c) Change-Id: Ie14704b132d684c4f8733b99ce2c44a0f4fab9f5 Signed-off-by: Adriana Kobylak <anoo@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
index 1e9fdd66f..7f71e7c01 100644
--- a/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
+++ b/meta-openpower/recipes-phosphor/network/first-boot-set-hostname_1.0.bb
@@ -10,13 +10,13 @@ RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_base-utils}"
SYSTEMD_SERVICE_${PN} = "first-boot-set-hostname.service"
-SRC_URI = "file://${PN}.sh file://${PN}.service"
+SRC_URI = "file://${BPN}.sh file://${BPN}.service"
S = "${WORKDIR}"
do_install() {
- sed "s/{MACHINE}/${MACHINE}/" -i ${PN}.sh
+ sed "s/{MACHINE}/${MACHINE}/" -i ${BPN}.sh
install -d ${D}${bindir} ${D}${systemd_system_unitdir}
- install ${PN}.sh ${D}${bindir}/
- install -m 644 ${PN}.service ${D}${systemd_system_unitdir}/
+ install ${BPN}.sh ${D}${bindir}/
+ install -m 644 ${BPN}.service ${D}${systemd_system_unitdir}/
}