summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2019-08-02 11:18:25 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-08-16 16:18:59 +0300
commit3d88bc91e7e95809fddd986fae90d870f0b8d6d2 (patch)
treeae2a8e7c3e9644f2d8ca1a7667ce50db36ab87a9 /meta-openpower
parent537361a6a33b26796e09d2a374be2d955c12177a (diff)
downloadopenbmc-3d88bc91e7e95809fddd986fae90d870f0b8d6d2.tar.xz
op-proc-control: Use libpdbg to issue NMI
(From meta-openpower rev: 075a2d9cadc92542d6a0527e77542d4507c11c12) Change-Id: I13df8506231521d6878450760322cf6ea0cfbc64 Signed-off-by: Andrew Jeffery <andrew@aj.id.au> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/host/op-proc-control_git.bb10
1 files changed, 1 insertions, 9 deletions
diff --git a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
index 05d6d90df..034dd3493 100644
--- a/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
+++ b/meta-openpower/recipes-phosphor/host/op-proc-control_git.bb
@@ -11,7 +11,7 @@ inherit autotools obmc-phosphor-utils pkgconfig pythonnative
inherit systemd
SRC_URI += "git://github.com/openbmc/openpower-proc-control"
-SRCREV = "16ab00cb9383b17b8dd033a1cb300e2a013d55b1"
+SRCREV = "424475d4b9c9af78813326c427225bf76a9236f9"
DEPENDS += " \
autoconf-archive-native \
@@ -23,13 +23,6 @@ DEPENDS += " \
# For libpdbg, provided by the pdbg package
DEPENDS += "pdbg"
-# For now, explicitly depend on the pdbg package for the pdbg binary at runtime
-# (as documentation). This will be removed shortly when we only depend on
-# libpdbg; the pdbg package will automatically injected into RDEPENDS by
-# bitbake as it is in DEPENDS and openpower-proc-nmi has a runtime link
-# dependency on libpdbg.
-RDEPENDS_${PN} += "pdbg"
-
TEMPLATE = "pcie-poweroff@.service"
INSTANCE_FORMAT = "pcie-poweroff@{}.service"
INSTANCES = "${@compose_list(d, 'INSTANCE_FORMAT', 'OBMC_CHASSIS_INSTANCES')}"
@@ -38,5 +31,4 @@ SYSTEMD_SERVICE_${PN} = "${TEMPLATE} ${INSTANCES}"
SYSTEMD_SERVICE_${PN} += " \
xyz.openbmc_project.Control.Host.NMI.service \
- nmi.service \
"