summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2020-04-01 00:43:15 +0300
committerAndrew Geissler <geissonator@yahoo.com>2020-04-07 02:46:50 +0300
commitba5282b0c7319b2c2c2e97d33a54eb813eb44119 (patch)
treeb4e498ae921159b3cc4dec1e3a0276172d5d4f0d /meta-openpower
parent1fa9b69ec23a1ce0fd685702ea65ebd4bf6e811b (diff)
downloadopenbmc-ba5282b0c7319b2c2c2e97d33a54eb813eb44119.tar.xz
meta-openpower: update DEPENDS for sdbusplus-native
sdbusplus has changed the package layout so that sdbusplus-native and sdbus++-native are now ${PYTHON_PN}-sdbus++-native. Update recipes that need to use sdbus++ (or its associated python modules) or remove the DEPENDS if it is no longer necessary. (From meta-openpower rev: d555f82d1a10a4c65377ae9b090996220a635c0d) Signed-off-by: Patrick Williams <patrick@stwcx.xyz> Change-Id: Ie79b13b1cce3ee14e89d895d325c021c68cf89bd Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb9
-rw-r--r--meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb2
-rw-r--r--meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb4
-rw-r--r--meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb2
4 files changed, 7 insertions, 10 deletions
diff --git a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
index 62eaf634c..3545018b3 100644
--- a/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
+++ b/meta-openpower/recipes-phosphor/dbus/openpower-dbus-interfaces_git.bb
@@ -8,25 +8,22 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
S = "${WORKDIR}/git"
inherit autotools pkgconfig
-inherit pythonnative
+inherit python3native
inherit phosphor-dbus-yaml
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbus++-native"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
DEPENDS += "phosphor-dbus-interfaces"
SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f"
-DEPENDS_remove_class-native = "sdbus++-native"
-DEPENDS_remove_class-nativesdk = "sdbus++-native"
-
PACKAGECONFIG ??= "libopenpower_dbus"
PACKAGECONFIG[libopenpower_dbus] = " \
--enable-libopenpower_dbus, \
--disable-libopenpower_dbus, \
systemd sdbusplus, \
- libsystemd sdbusplus \
+ libsystemd \
"
PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
diff --git a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
index d79a01c5e..4e4362571 100644
--- a/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
+++ b/meta-openpower/recipes-phosphor/debug/openpower-debug-collector_git.bb
@@ -15,7 +15,7 @@ require ${PN}.inc
DEPENDS += " \
phosphor-logging \
autoconf-archive-native \
- sdbus++-native \
+ ${PYTHON_PN}-sdbus++-native \
"
S = "${WORKDIR}/git"
diff --git a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
index 711b7e6a3..93b94a4f5 100644
--- a/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
+++ b/meta-openpower/recipes-phosphor/ipmi/openpower-ipmi-oem_git.bb
@@ -13,11 +13,11 @@ require ${PN}.inc
DEPENDS += "phosphor-ipmi-host"
DEPENDS += "autoconf-archive-native"
-DEPENDS += "sdbusplus sdbusplus-native"
+DEPENDS += "sdbusplus"
+DEPENDS += "${PYTHON_PN}-sdbus++-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
DEPENDS += "openpower-dbus-interfaces openpower-dbus-interfaces-native"
-DEPENDS += "sdbus++-native"
DEPENDS += "virtual/phosphor-ipmi-inventory-sel"
TARGET_CFLAGS += "-fpic"
diff --git a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
index 0f90160e6..9fcf93b0c 100644
--- a/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
+++ b/meta-openpower/recipes-phosphor/occ/openpower-occ-control_git.bb
@@ -26,7 +26,7 @@ SYSTEMD_SERVICE_${PN} += "op-occ-disable@.service"
DEPENDS += "virtual/${PN}-config-native"
DEPENDS += " \
sdbusplus \
- sdbusplus-native \
+ ${PYTHON_PN}-sdbus++-native \
phosphor-logging \
phosphor-dbus-interfaces \
autoconf-archive-native \