summaryrefslogtreecommitdiff
path: root/meta-openpower
diff options
context:
space:
mode:
authorJayanth Othayoth <ojayanth@in.ibm.com>2021-10-22 14:03:59 +0300
committerAndrew Geissler <geissonator@yahoo.com>2021-10-26 15:43:13 +0300
commit9657ed3a430000aa40231e97d8bcaeb2a88fb247 (patch)
treed6a118b91b6a6c5b0248915758ee7d8e23715e64 /meta-openpower
parentc8dbbb56e89ded4141ffa904a8f8581c9c6fd948 (diff)
downloadopenbmc-9657ed3a430000aa40231e97d8bcaeb2a88fb247.tar.xz
openpower: ecmd-pdbg initial commit
The code in this repo provides the glue code necessary for pdbg to be used as an eCMD plugin. Signed-off-by: Jayanth Othayoth <ojayanth@in.ibm.com> Change-Id: Id1e621025d3ee2f536bf0936533068dc202c0c65
Diffstat (limited to 'meta-openpower')
-rw-r--r--meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb b/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb
new file mode 100644
index 000000000..df98965af
--- /dev/null
+++ b/meta-openpower/recipes-bsp/ecmd-pdbg/ecmd-pdbg_1.0.bb
@@ -0,0 +1,23 @@
+SUMMARY = "eCMD plugin with pdbg backend"
+DESCRIPTION = "The glue code necessary for pdbg to be used as an eCMD plugin"
+PR = "r1"
+PV = "1.0+git${SRCPV}"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
+
+inherit meson
+inherit pkgconfig
+
+SRC_URI = "git://git@github.com/open-power/ecmd-pdbg.git"
+SRCREV = "349e04048409b4a619f4bc979aa5dd76e2bbc665"
+
+S = "${WORKDIR}/git"
+
+DEPENDS = "pdbg zlib libyaml ipl"
+
+FILES:${PN} += "${prefix}/help"
+
+EXTRA_OEMESON = " \
+ -Dchip=p10 \
+ "