summaryrefslogtreecommitdiff
path: root/meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-24 06:32:26 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-06-11 17:16:24 +0300
commit01ddfab322ae50bedaa250630661ebed0c1a9101 (patch)
treeb87010b45ba17d439101302b559e7edca09b0a6c /meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc
parent9c8c98545becdb348a6d72f68071d15d1cacff8e (diff)
downloadopenbmc-01ddfab322ae50bedaa250630661ebed0c1a9101.tar.xz
Use BB collections for Aspeed tree patches
Move the Aspeed u-boot tree patches to a directory where they can be conditionally applied when the Aspeed layer is in the build configuration. This is a better way to achieve 273ec60e436 since it enables the Aspeed BSP layer to name its u-boot/kernel recipes whatever it wants. Remove stubbed do_configure from u-boot_%.bbappend. It is no longer required since the bbappend is only activated when the aspeed layer and associated u-boot recipes are in the layer configuration. Tested: Built u-boot recipe for witherspoon and palmetto targets Change-Id: I52dceb65598e0cf660ad035a8f14e9894325ca71 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc')
-rw-r--r--meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc b/meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc
new file mode 100644
index 000000000..5286c1b0a
--- /dev/null
+++ b/meta-phosphor/aspeed-layer/recipes-bsp/u-boot/u-boot-aspeed.inc
@@ -0,0 +1,23 @@
+inherit image_version
+
+SRC_URI_append_aspeed = " file://0001-configs-ast-Add-redundnant-env.patch"
+
+SRC_URI_append_aspeed_df-obmc-ubi-fs = " \
+ file://0002-config-ast-common-hack-bootopts.patch \
+ file://0003-config-ast-common-Add-bootopts-to-support-ubi-and-mt.patch \
+ file://0004-config-ast-common-Add-conditional-factory-reset-comm.patch \
+ file://0005-config-ast-common-Fall-back-to-secondary-flash-on-fa.patch \
+ "
+
+do_patch[depends] += "os-release:do_populate_sysroot"
+
+python do_patch_append_aspeed_df-obmc-ubi-fs () {
+ version_id=do_get_versionID(d)
+ d.setVar('VERSION_ID', version_id)
+ bb.build.exec_func("patch_kernelname", d)
+}
+
+patch_kernelname () {
+ sed -ri "s/kernel-(0|[a-fA-F0-9]{8})/kernel-${VERSION_ID}/g" \
+ ${S}/include/configs/ast-common.h &> /dev/null
+}