summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-core
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2018-07-19 21:44:03 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-24 16:45:12 +0300
commit3e4d0942a9b093e201f9f343a43d106cd3733ed3 (patch)
tree7a5e9f1c552f9a2822337ddfa3cecc40eb6f9bcd /meta-phosphor/common/recipes-core
parent3420d9dabd264d397776099d992fa4d6dd06cb1c (diff)
downloadopenbmc-3e4d0942a9b093e201f9f343a43d106cd3733ed3.tar.xz
Move phosphor overrides of systemd into own recipe
Phosphor specific overrides to systemd should be stored within its own recipe and pulled in via the phosphor layer. This helps distinguish systemd specific overrides with phosphor overrides. Tested: Verified service-restart-policy.conf was still pulled in as expected in witherspoon QEMU Change-Id: I32110fc2edd3abd2bb0008c63dd4ad7828b762b8 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-phosphor/common/recipes-core')
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd/service-restart-policy.conf31
-rw-r--r--meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend3
2 files changed, 0 insertions, 34 deletions
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd/service-restart-policy.conf b/meta-phosphor/common/recipes-core/systemd/systemd/service-restart-policy.conf
deleted file mode 100644
index 0bd049b41..000000000
--- a/meta-phosphor/common/recipes-core/systemd/systemd/service-restart-policy.conf
+++ /dev/null
@@ -1,31 +0,0 @@
-# This file overrides some defaults for systemd
-#
-# - Change the RestartSec from 100ms to 1s.
-# When a service hits a failure, our new debug collection service kicks
-# in. When a core file is involved, it's been found that generating 5 core
-# files within ~500ms puts a huge strain on the BMC. Also, if the bmc is
-# going to get a fix on a restart of a service, the more time the better
-# (think retries on device driver scenarios).
-#
-# - Change the StartLimitBurst to 2
-# Five just seems excessive for our services in openbmc. In all fail
-# scenarios seen so far (other then with phosphor-hwmon), either
-# restarting once does the job or restarting all 5 times does not help
-# and we just end up hitting the 5 limit anyway.
-#
-# - Change the StartLimitIntervalSec to 30s
-# The BMC CPU performance is already challenged. When a service is
-# failing and a core dump is being generated and collected into a dump,
-# it's even more challenged. Recent failures have shown situations where
-# the service does not fail again until 15-20 seconds after the initial
-# failure which means the default of 10s for this results in the service
-# being restarted indefinitely. Change this to 30s to only allow a service
-# to be restarted StartLimitBurst times within a 30s interval before
-# being put in a permenant fail state.
-#
-# See systemd-system.conf(5) for details on the conf files
-
-[Manager]
-DefaultRestartSec=1s
-DefaultStartLimitBurst=2
-DefaultStartLimitIntervalSec=30s
diff --git a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
index 07b3038d0..b403069a5 100644
--- a/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-phosphor/common/recipes-core/systemd/systemd_%.bbappend
@@ -7,7 +7,6 @@ PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
manpages"
FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
SRC_URI += "file://default.network"
-SRC_URI += "file://service-restart-policy.conf"
SRC_URI += "file://0001-sd-bus-Don-t-automatically-add-ObjectManager.patch"
SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
@@ -17,9 +16,7 @@ SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.
RRECOMMENDS_${PN} += "obmc-targets"
FILES_${PN} += "${systemd_unitdir}/network/default.network"
-FILES_${PN} += "${systemd_unitdir}/system.conf.d/service-restart-policy.conf"
do_install_append() {
install -m 644 ${WORKDIR}/default.network ${D}${systemd_unitdir}/network/
- install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${systemd_unitdir}/system.conf.d/service-restart-policy.conf
}