summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-devtools/python
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@us.ibm.com>2015-10-19 17:33:11 +0300
committerBrad Bishop <bradleyb@us.ibm.com>2015-10-19 21:21:44 +0300
commit93366ffafb7654dcc9968e7c913095555555ac96 (patch)
tree5ed6af7cfb1cf53ed20abd5f291060ad090ca932 /meta-phosphor/common/recipes-devtools/python
parent20dd1bda0d816c4c7da106a09dde5ae817e89448 (diff)
downloadopenbmc-93366ffafb7654dcc9968e7c913095555555ac96.tar.xz
Add recipe for https://github.com/msoulier/tftpy
A pure python library for TFTP.
Diffstat (limited to 'meta-phosphor/common/recipes-devtools/python')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-tftpy.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-tftpy.bb b/meta-phosphor/common/recipes-devtools/python/python-tftpy.bb
new file mode 100644
index 000000000..32f788b23
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-tftpy.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Python is a TFTP library for the Python programming language."
+DESCRIPTION = "Tftpy is a TFTP library for the Python programming language. It includes \
+client and server classes, with sample implementations. Hooks are included for \
+easy inclusion in a UI for populating progress indicators. It supports RFCs \
+1350, 2347, 2348 and the tsize option from RFC 2349."
+HOMEPAGE = "https://github.com/msoulier/tftpy"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=22770e72ae03c61f5bcc4e333b61368d"
+
+SRC_URI = "git://github.com/msoulier/tftpy.git"
+SRCREV = "${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+inherit allarch
+inherit setuptools
+
+BBCLASSEXTEND = "nativesdk"