summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-devtools/python
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-16 20:14:28 +0300
committerPatrick Williams <patrick@stwcx.xyz>2016-08-16 20:14:28 +0300
commitbea797d88a1ed9c65bd0187a56541260dadbb631 (patch)
treee078d27a9e2c7c88439306329eff151f61f9da02 /meta-phosphor/common/recipes-devtools/python
parentace237750bb1acfc86aba9fddc16c1dfa74332dd (diff)
downloadopenbmc-bea797d88a1ed9c65bd0187a56541260dadbb631.tar.xz
python: Install full email package for native[sdk]
The .bbappend for python creates a minimal email package for installation on the target, but was also impacting nativesdk packages. This prevented us from compiling certain python programs inside the SDK. Change the do_install_append to only impact targets (and not native/nativesdk). Change-Id: I68576d7f1f98892840a09ed382690ea4b3aa3940 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools/python')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python_2.7.11.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python_2.7.11.bbappend b/meta-phosphor/common/recipes-devtools/python/python_2.7.11.bbappend
index a4df15b9f..569e75397 100644
--- a/meta-phosphor/common/recipes-devtools/python/python_2.7.11.bbappend
+++ b/meta-phosphor/common/recipes-devtools/python/python_2.7.11.bbappend
@@ -1,7 +1,7 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "file://__init__.email_min.py"
-do_install_append() {
+do_install_append_class-target() {
dir=${libdir}/python${PYTHON_MAJMIN}/email
mv ${D}/$dir/__init__.py \
${D}/$dir/email_full.py