summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-16 18:16:46 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-03-23 16:19:10 +0300
commitc1c98009aa21ab8b336693495d009d279e5b54d6 (patch)
treedef933e8f56e8b04099ae7ec05413708e93f70f1 /meta-phosphor/common/recipes-devtools
parenta9c1a77edeaa280481488d567c93dca5fa3fd37b (diff)
downloadopenbmc-c1c98009aa21ab8b336693495d009d279e5b54d6.tar.xz
python-*: use pypi class
Cleanup the various python-* recipes which download from pypi. The biggest change is to "inherit pypi" which should result in us always using current pypi best practices. This will for example ensure we are using https and not http. Change-Id: I3e818284efb8094e64b004af22781c8a3fcb89b3 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-bottle.inc2
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-bottle_0.12.13.bb13
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb7
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-inflection.inc2
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb6
5 files changed, 14 insertions, 16 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-bottle.inc b/meta-phosphor/common/recipes-devtools/python/python-bottle.inc
index ed4744df3..129c059d5 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-bottle.inc
+++ b/meta-phosphor/common/recipes-devtools/python/python-bottle.inc
@@ -11,8 +11,8 @@ LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=94b9b2cc7e46ccea87e00af8970826
inherit allarch
inherit setuptools
+inherit pypi
-S = "${WORKDIR}/${SRCNAME}-${PV}"
RDEPENDS_${PN} += " \
python-email-utils \
python-json \
diff --git a/meta-phosphor/common/recipes-devtools/python/python-bottle_0.12.13.bb b/meta-phosphor/common/recipes-devtools/python/python-bottle_0.12.13.bb
index 590a3eb75..08d84ff4a 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-bottle_0.12.13.bb
+++ b/meta-phosphor/common/recipes-devtools/python/python-bottle_0.12.13.bb
@@ -1,5 +1,10 @@
-SRCNAME = "bottle"
-SRC_URI = "https://pypi.python.org/packages/bd/99/04dc59ced52a8261ee0f965a8968717a255ea84a36013e527944dbf3468c/${SRCNAME}-${PV}.tar.gz;name=tarball file://LICENSE file://json-format.patch"
-SRC_URI[tarball.sha256sum] = "39b751aee0b167be8dffb63ca81b735bbf1dd0905b3bc42761efedee8f123355"
-SRC_URI[tarball.md5sum] = "d2fe1b48c1d49217e78bf326b1cad437"
+SRC_URI[sha256sum] = "39b751aee0b167be8dffb63ca81b735bbf1dd0905b3bc42761efedee8f123355"
+SRC_URI[md5sum] = "d2fe1b48c1d49217e78bf326b1cad437"
+
+# There is no license on pypi. See:
+# https://github.com/bottlepy/bottle/commit/55a505b3a54bb7de23e9554cb8ce7f8e160c31a0
+SRC_URI += "file://LICENSE"
+
+SRC_URI += "file://json-format.patch"
+
require python-bottle.inc
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb b/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
index 930ec3a99..8ac2a8982 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
@@ -11,12 +11,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5aa2f1d4ea55d60497aa8c3debf29ab2"
RDEPENDS_${PN} = "python-gevent"
-SRCNAME = "gevent-websocket"
-
-SRC_URI = "https://pypi.python.org/packages/98/d2/6fa19239ff1ab072af40ebf339acd91fb97f34617c2ee625b8e34bf42393/gevent-websocket-${PV}.tar.gz"
SRC_URI[md5sum] = "e095bf3358175489a956949c1b4de9ff"
SRC_URI[sha256sum] = "7eaef32968290c9121f7c35b973e2cc302ffb076d018c9068d2f5ca8b2d85fb0"
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit setuptools
+inherit setuptools pypi
diff --git a/meta-phosphor/common/recipes-devtools/python/python-inflection.inc b/meta-phosphor/common/recipes-devtools/python/python-inflection.inc
index 819b3682f..71d218cb2 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-inflection.inc
+++ b/meta-phosphor/common/recipes-devtools/python/python-inflection.inc
@@ -9,8 +9,8 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=de7833d9c2ce0052a4073928c76a13d7"
inherit allarch
inherit setuptools
+inherit pypi
-S = "${WORKDIR}/${SRCNAME}-${PV}"
RDEPENDS_${PN} += " \
${PYTHON_PN}-re \
${PYTHON_PN}-codecs \
diff --git a/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
index ce19f99a4..318171c89 100644
--- a/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
+++ b/meta-phosphor/common/recipes-devtools/python/python-inflection_0.3.1.bb
@@ -1,5 +1,3 @@
-SRCNAME = "inflection"
-SRC_URI = "https://pypi.python.org/packages/source/i/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=tarball"
-SRC_URI[tarball.sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
-SRC_URI[tarball.md5sum] = "7941165e9f148e0520023941c0886b40"
+SRC_URI[sha256sum] = "18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca"
+SRC_URI[md5sum] = "7941165e9f148e0520023941c0886b40"
require python-inflection.inc