summaryrefslogtreecommitdiff
path: root/meta-phosphor/common/recipes-devtools
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-01-25 13:31:07 +0300
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-01 00:55:58 +0300
commite2264f0515c856a84b2e48b8fdd5b44055816333 (patch)
tree7120597dc4ae153921b178aef1954b3ae302db55 /meta-phosphor/common/recipes-devtools
parent41e65a04d146659d89206509ac18f21d389d4f8c (diff)
downloadopenbmc-e2264f0515c856a84b2e48b8fdd5b44055816333.tar.xz
gevent-websocket: move to Phosphor layer
This recipe was erroneously merged directly into the meta-virt subtree with 1ea01342e. Move to the phosphor layer. Tested: Built an image and verified gevent-websocket still installed Change-Id: I33eba0dedbd5ff2a522ddab526e5787345a2f5d5 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-phosphor/common/recipes-devtools')
-rw-r--r--meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb b/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
new file mode 100644
index 000000000..930ec3a99
--- /dev/null
+++ b/meta-phosphor/common/recipes-devtools/python/python-gevent-websocket_0.10.1.bb
@@ -0,0 +1,22 @@
+HOMEPAGE = "https://bitbucket.org/noppo/gevent-websocket"
+SUMMARY = "A websocket library for gevent Python networking library"
+DESCRIPTION = "\
+ WebSocket is a computer communications protocol, providing full-duplex \
+ communication channels over a single TCP connection. gevent-websocket \
+ library provides websocket support for gevent. \
+ "
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5aa2f1d4ea55d60497aa8c3debf29ab2"
+
+RDEPENDS_${PN} = "python-gevent"
+
+SRCNAME = "gevent-websocket"
+
+SRC_URI = "https://pypi.python.org/packages/98/d2/6fa19239ff1ab072af40ebf339acd91fb97f34617c2ee625b8e34bf42393/gevent-websocket-${PV}.tar.gz"
+SRC_URI[md5sum] = "e095bf3358175489a956949c1b4de9ff"
+SRC_URI[sha256sum] = "7eaef32968290c9121f7c35b973e2cc302ffb076d018c9068d2f5ca8b2d85fb0"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools